aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-11-01 13:26:28 -0700
committerKhem Raj <raj.khem@gmail.com>2021-11-02 08:07:17 -0700
commitf0690901469d22e2616fb3094adf6d0f39d00fb9 (patch)
treed372fd5935922d678d1ad3f56d0e43fea08eeda0
parentd08d088a47a75d74e53179dca157289e73b27404 (diff)
downloadmeta-openembedded-contrib-f0690901469d22e2616fb3094adf6d0f39d00fb9.tar.gz
mozjs-78: Set X lib/include paths
mozjs does not really use X but arcane autoconf 2.13 means its poking at build host for X headers and libraries. On build hosts where X is installed this results in wrong paths being searched for target X headers, this gets caught by configure QA and it fails ERROR: mozjs-78-78.15.0-r0 do_configure: QA Issue: This autoconf log indicates errors, it looked at host include and/or library paths while determining system capabilities. Rerun configure task after fixing this. [configure-unsafe] ERROR: mozjs-78-78.15.0-r0 do_configure: Fatal QA errors were found, failing task. Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/dynamic-layers/meta-python/recipes-extended/mozjs/mozjs-78_78.15.0.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta-oe/dynamic-layers/meta-python/recipes-extended/mozjs/mozjs-78_78.15.0.bb b/meta-oe/dynamic-layers/meta-python/recipes-extended/mozjs/mozjs-78_78.15.0.bb
index f0cd6e0ec5..090c2fe058 100644
--- a/meta-oe/dynamic-layers/meta-python/recipes-extended/mozjs/mozjs-78_78.15.0.bb
+++ b/meta-oe/dynamic-layers/meta-python/recipes-extended/mozjs/mozjs-78_78.15.0.bb
@@ -41,13 +41,14 @@ EXTRA_OECONF = " \
--host=${BUILD_SYS} \
--prefix=${prefix} \
--libdir=${libdir} \
+ --x-includes=${STAGING_INCDIR} \
+ --x-libraries=${STAGING_LIBDIR} \
--without-system-icu \
--disable-tests --disable-strip --disable-optimize \
--disable-jemalloc \
${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', "--enable-gold", '--disable-gold', d)} \
${JIT} \
"
-
# Note: Python with mozilla build is a mess: E.g: python-six: to get an error
# free configure we need:
# * python3-six-native in DEPENDS