aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorStanislav Angelovic <stanislav.angelovic@siemens.com>2021-11-02 13:42:12 +0100
committerKhem Raj <raj.khem@gmail.com>2021-11-02 08:07:17 -0700
commite6464f0871c82a7935c3e645aa15f56baad28d22 (patch)
treedcbec5c086254d8c15125f127e26b2565d7d66f0
parent48d5f9bfd65c81612fa92f4b48e63bab5cd3069a (diff)
downloadmeta-openembedded-contrib-e6464f0871c82a7935c3e645aa15f56baad28d22.tar.gz
Bump sdbus-c++ to version v1.0.0
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-core/sdbus-c++/sdbus-c++-0.8.3/0001-Do-not-download-gtest-automatically.patch44
-rw-r--r--meta-oe/recipes-core/sdbus-c++/sdbus-c++-0.8.3/0001-test-Check-for-googletest-on-system-first.patch41
-rwxr-xr-xmeta-oe/recipes-core/sdbus-c++/sdbus-c++-1.0.0/run-ptest (renamed from meta-oe/recipes-core/sdbus-c++/sdbus-c++-0.8.3/run-ptest)0
-rw-r--r--meta-oe/recipes-core/sdbus-c++/sdbus-c++-tools_1.0.0.bb (renamed from meta-oe/recipes-core/sdbus-c++/sdbus-c++-tools_0.8.3.bb)2
-rw-r--r--meta-oe/recipes-core/sdbus-c++/sdbus-c++_1.0.0.bb (renamed from meta-oe/recipes-core/sdbus-c++/sdbus-c++_0.8.3.bb)11
5 files changed, 4 insertions, 94 deletions
diff --git a/meta-oe/recipes-core/sdbus-c++/sdbus-c++-0.8.3/0001-Do-not-download-gtest-automatically.patch b/meta-oe/recipes-core/sdbus-c++/sdbus-c++-0.8.3/0001-Do-not-download-gtest-automatically.patch
deleted file mode 100644
index 5bd3801f38..0000000000
--- a/meta-oe/recipes-core/sdbus-c++/sdbus-c++-0.8.3/0001-Do-not-download-gtest-automatically.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-From af91a20ee201f13e56f225df536a56e5d8d259e8 Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Thu, 27 May 2021 09:56:49 -0700
-Subject: [PATCH] Do not download gtest automatically
-
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- tests/CMakeLists.txt | 9 +--------
- tests/googletest-download/CMakeLists.txt.in | 3 ---
- 2 files changed, 1 insertion(+), 11 deletions(-)
-
---- a/tests/googletest-download/CMakeLists.txt.in
-+++ b/tests/googletest-download/CMakeLists.txt.in
-@@ -7,10 +7,7 @@ project(googletest-download NONE)
- include(ExternalProject)
-
- ExternalProject_Add(googletest
-- GIT_REPOSITORY https://github.com/google/googletest.git
-- GIT_TAG master
-- GIT_SHALLOW 1
-- SOURCE_DIR "${CMAKE_CURRENT_BINARY_DIR}/googletest-src"
-+ SOURCE_DIR "${CMAKE_CURRENT_SOURCE_DIR}/googletest-src"
- BINARY_DIR "${CMAKE_CURRENT_BINARY_DIR}/googletest-build"
- UPDATE_COMMAND ""
- CONFIGURE_COMMAND ""
---- a/tests/CMakeLists.txt
-+++ b/tests/CMakeLists.txt
-@@ -6,9 +6,7 @@ include(FetchContent)
-
- message("Fetching googletest...")
- FetchContent_Declare(googletest
-- GIT_REPOSITORY https://github.com/google/googletest.git
-- GIT_TAG master
-- GIT_SHALLOW 1
-+ SOURCE_DIR ${CMAKE_CURRENT_SOURCE_DIR}/googletest-src
- UPDATE_COMMAND "")
-
- #FetchContent_MakeAvailable(googletest) # Not available in CMake 3.13 :-( Let's do it manually:
-@@ -144,4 +142,4 @@ endif()
- if(NOT CMAKE_CROSSCOMPILING)
- add_test(NAME sdbus-c++-unit-tests COMMAND sdbus-c++-unit-tests)
- add_test(NAME sdbus-c++-integration-tests COMMAND sdbus-c++-integration-tests)
--endif()
-+endif()
diff --git a/meta-oe/recipes-core/sdbus-c++/sdbus-c++-0.8.3/0001-test-Check-for-googletest-on-system-first.patch b/meta-oe/recipes-core/sdbus-c++/sdbus-c++-0.8.3/0001-test-Check-for-googletest-on-system-first.patch
deleted file mode 100644
index 8a6aceac87..0000000000
--- a/meta-oe/recipes-core/sdbus-c++/sdbus-c++-0.8.3/0001-test-Check-for-googletest-on-system-first.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-From dc5fa7a4b342ef80cda533cdb821841d8183287c Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Sun, 23 May 2021 09:01:09 -0700
-Subject: [PATCH] test: Check for googletest on system first
-
-This ensures if googletest is instslled already then use that version
-before downloading and building own copy
-
-Upstream-Status: Pending
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- tests/CMakeLists.txt | 6 +++++-
- 1 file changed, 5 insertions(+), 1 deletion(-)
-
-diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
-index 97f7c1a..3dfdd1c 100644
---- a/tests/CMakeLists.txt
-+++ b/tests/CMakeLists.txt
-@@ -2,6 +2,10 @@
- # DOWNLOAD AND BUILD OF GOOGLETEST
- #-------------------------------
-
-+find_package(GTest)
-+
-+if(NOT GTest_FOUND)
-+
- include(FetchContent)
-
- message("Fetching googletest...")
-@@ -23,7 +27,7 @@ if(NOT googletest_POPULATED)
- add_subdirectory(${googletest_SOURCE_DIR} ${googletest_BINARY_DIR})
- set(BUILD_SHARED_LIBS ${BUILD_SHARED_LIBS_BAK})
- endif()
--
-+endif()
- #-------------------------------
- # SOURCE FILES CONFIGURATION
- #-------------------------------
---
-2.31.1
-
diff --git a/meta-oe/recipes-core/sdbus-c++/sdbus-c++-0.8.3/run-ptest b/meta-oe/recipes-core/sdbus-c++/sdbus-c++-1.0.0/run-ptest
index f6ade0c7e4..f6ade0c7e4 100755
--- a/meta-oe/recipes-core/sdbus-c++/sdbus-c++-0.8.3/run-ptest
+++ b/meta-oe/recipes-core/sdbus-c++/sdbus-c++-1.0.0/run-ptest
diff --git a/meta-oe/recipes-core/sdbus-c++/sdbus-c++-tools_0.8.3.bb b/meta-oe/recipes-core/sdbus-c++/sdbus-c++-tools_1.0.0.bb
index 3b87c22653..35e9401607 100644
--- a/meta-oe/recipes-core/sdbus-c++/sdbus-c++-tools_0.8.3.bb
+++ b/meta-oe/recipes-core/sdbus-c++/sdbus-c++-tools_1.0.0.bb
@@ -8,7 +8,7 @@ inherit cmake
DEPENDS += "expat"
-SRCREV = "6e8e5aadb674cccea5bdd55141db5dad887fbacd"
+SRCREV = "65782bbf435d91e5eb6af9ddab110df406a824a9"
SRC_URI = "git://github.com/Kistler-Group/sdbus-cpp.git;protocol=https;branch=master;subpath=tools"
S = "${WORKDIR}/tools"
diff --git a/meta-oe/recipes-core/sdbus-c++/sdbus-c++_0.8.3.bb b/meta-oe/recipes-core/sdbus-c++/sdbus-c++_1.0.0.bb
index 12eae5c7d5..0469ac9509 100644
--- a/meta-oe/recipes-core/sdbus-c++/sdbus-c++_0.8.3.bb
+++ b/meta-oe/recipes-core/sdbus-c++/sdbus-c++_1.0.0.bb
@@ -12,18 +12,13 @@ PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'with-exte
${@bb.utils.contains('PTEST_ENABLED', '1', 'with-tests', '', d)}"
PACKAGECONFIG[with-builtin-libsystemd] = ",,sdbus-c++-libsystemd,libcap"
PACKAGECONFIG[with-external-libsystemd] = ",,systemd,libsystemd"
-PACKAGECONFIG[with-tests] = "-DBUILD_TESTS=ON -DTESTS_INSTALL_PATH=${libdir}/${BPN}/tests,-DBUILD_TESTS=OFF"
+PACKAGECONFIG[with-tests] = "-DBUILD_TESTS=ON -DTESTS_INSTALL_PATH=${libdir}/${BPN}/tests,-DBUILD_TESTS=OFF,googletest,gmock"
DEPENDS += "expat"
-SRCREV = "6e8e5aadb674cccea5bdd55141db5dad887fbacd"
-SRCREV_gtest = "a3460d1aeeaa43fdf137a6adefef10ba0b59fe4b"
-SRCREV_FORMAT = "default_gtest"
+SRCREV = "65782bbf435d91e5eb6af9ddab110df406a824a9"
-SRC_URI = "git://github.com/Kistler-Group/sdbus-cpp.git;protocol=https;branch=master \
- git://github.com/google/googletest.git;protocol=https;branch=master;name=gtest;destsuffix=git/tests/googletest-src \
- file://0001-Do-not-download-gtest-automatically.patch \
-"
+SRC_URI = "git://github.com/Kistler-Group/sdbus-cpp.git;protocol=https;branch=master"
SRC_URI += "file://run-ptest"
EXTRA_OECMAKE = "-DBUILD_CODE_GEN=ON \