aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmail.com>2021-11-01 12:49:21 +0100
committerKhem Raj <raj.khem@gmail.com>2021-11-02 08:07:17 -0700
commit2fbed4dff5a3245a593eef45eae497bc049d56f2 (patch)
tree421f5fe7bddaf08b5b39823d5ab6623754f3eead
parenta61c0a9e1367fa1bc01c5469768203c38fe23786 (diff)
downloadmeta-openembedded-contrib-2fbed4dff5a3245a593eef45eae497bc049d56f2.tar.gz
gnome-shell: upgrade 3.34.5 -> 41.0
Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-gnome/recipes-gnome/gnome-shell/gnome-shell/0001-Introduce-options-gjs_path-to-optionally-set-path-to.patch112
-rw-r--r--meta-gnome/recipes-gnome/gnome-shell/gnome-shell_41.0.bb (renamed from meta-gnome/recipes-gnome/gnome-shell/gnome-shell_3.34.5.bb)12
2 files changed, 120 insertions, 4 deletions
diff --git a/meta-gnome/recipes-gnome/gnome-shell/gnome-shell/0001-Introduce-options-gjs_path-to-optionally-set-path-to.patch b/meta-gnome/recipes-gnome/gnome-shell/gnome-shell/0001-Introduce-options-gjs_path-to-optionally-set-path-to.patch
new file mode 100644
index 0000000000..15e3c8c647
--- /dev/null
+++ b/meta-gnome/recipes-gnome/gnome-shell/gnome-shell/0001-Introduce-options-gjs_path-to-optionally-set-path-to.patch
@@ -0,0 +1,112 @@
+From 3bf597b16e23cd2ce0ee3b05c23b46add5e26cd4 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmail.com>
+Date: Thu, 28 Oct 2021 18:57:24 +0200
+Subject: [PATCH] Introduce options 'gjs_path' to optionally set path to gjs
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Upstream-Status: Pending
+
+Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
+---
+ js/dbusServices/meson.build | 2 +-
+ meson.build | 6 +++++-
+ meson_options.txt | 6 ++++++
+ subprojects/extensions-app/js/meson.build | 2 +-
+ subprojects/extensions-app/meson.build | 7 ++++++-
+ subprojects/extensions-app/meson_options.txt | 6 ++++++
+ 6 files changed, 25 insertions(+), 4 deletions(-)
+
+diff --git a/js/dbusServices/meson.build b/js/dbusServices/meson.build
+index 68e8bd12d..16efaebe5 100644
+--- a/js/dbusServices/meson.build
++++ b/js/dbusServices/meson.build
+@@ -27,7 +27,7 @@ foreach service, dir : dbus_services
+
+ serviceconf = configuration_data()
+ serviceconf.set('service', service)
+- serviceconf.set('gjs', gjs.path())
++ serviceconf.set('gjs', gjs)
+ serviceconf.set('pkgdatadir', pkgdatadir)
+
+ configure_file(
+diff --git a/meson.build b/meson.build
+index d4583ecf2..3448c6312 100644
+--- a/meson.build
++++ b/meson.build
+@@ -138,7 +138,11 @@ endif
+
+ mutter_typelibdir = mutter_dep.get_pkgconfig_variable('typelibdir')
+ python = find_program('python3')
+-gjs = find_program('gjs')
++if get_option('gjs_path') == ''
++ gjs = find_program('gjs')
++else
++ gjs = get_option('gjs_path')
++endif
+
+ cc = meson.get_compiler('c')
+
+diff --git a/meson_options.txt b/meson_options.txt
+index f0f2ecf6c..a45f2e453 100644
+--- a/meson_options.txt
++++ b/meson_options.txt
+@@ -45,3 +45,9 @@ option('soup2',
+ value: true,
+ description: 'Use Soup 2.4 instead of Soup 3. Must be in sync with libgweather'
+ )
++
++option('gjs_path',
++ type: 'string',
++ value: '',
++ description: 'Instead of searching gjs executable, configure path'
++)
+diff --git a/subprojects/extensions-app/js/meson.build b/subprojects/extensions-app/js/meson.build
+index f311db6e0..8f7bba4e4 100644
+--- a/subprojects/extensions-app/js/meson.build
++++ b/subprojects/extensions-app/js/meson.build
+@@ -9,7 +9,7 @@ endif
+ launcherconf.set('prefix', prefix)
+ launcherconf.set('libdir', libdir)
+ launcherconf.set('pkgdatadir', pkgdatadir)
+-launcherconf.set('gjs', gjs.path())
++launcherconf.set('gjs', gjs)
+
+ configure_file(
+ input: prgname + '.in',
+diff --git a/subprojects/extensions-app/meson.build b/subprojects/extensions-app/meson.build
+index f9ccfc24d..bdf118975 100644
+--- a/subprojects/extensions-app/meson.build
++++ b/subprojects/extensions-app/meson.build
+@@ -44,7 +44,12 @@ localedir = join_paths(datadir, 'locale')
+ metainfodir = join_paths(datadir, 'metainfo')
+ servicedir = join_paths(datadir, 'dbus-1', 'services')
+
+-gjs = find_program('gjs')
++if get_option('gjs_path') == ''
++ gjs = find_program('gjs')
++else
++ gjs = get_option('gjs_path')
++endif
++
+ appstream_util = find_program('appstream-util', required: false)
+ desktop_file_validate = find_program('desktop-file-validate', required: false)
+
+diff --git a/subprojects/extensions-app/meson_options.txt b/subprojects/extensions-app/meson_options.txt
+index ca2eb4115..2787785bf 100644
+--- a/subprojects/extensions-app/meson_options.txt
++++ b/subprojects/extensions-app/meson_options.txt
+@@ -10,3 +10,9 @@ option('profile',
+ ],
+ value: 'default'
+ )
++
++option('gjs_path',
++ type: 'string',
++ value: '',
++ description: 'Instead of searching gjs executable, configure path'
++)
+--
+2.31.1
+
diff --git a/meta-gnome/recipes-gnome/gnome-shell/gnome-shell_3.34.5.bb b/meta-gnome/recipes-gnome/gnome-shell/gnome-shell_41.0.bb
index b1aa519a05..6ac2973b9e 100644
--- a/meta-gnome/recipes-gnome/gnome-shell/gnome-shell_3.34.5.bb
+++ b/meta-gnome/recipes-gnome/gnome-shell/gnome-shell_41.0.bb
@@ -4,14 +4,14 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
GNOMEBASEBUILDCLASS = "meson"
-inherit gnomebase gsettings gettext gobject-introspection features_check upstream-version-is-even bash-completion
+inherit gnomebase gsettings gettext gobject-introspection features_check bash-completion
REQUIRED_DISTRO_FEATURES = "x11 polkit systemd pam"
DEPENDS = " \
libxml2-native \
sassc-native \
- gtk+3 \
+ gtk4 \
mutter \
evolution-data-server \
gcr \
@@ -30,8 +30,8 @@ GTKDOC_MESON_OPTION = "gtk_doc"
REQUIRED_DISTRO_FEATURES += "gobject-introspection-data"
UNKNOWN_CONFIGURE_WHITELIST:append = " introspection"
-SRC_URI[archive.md5sum] = "4bd27c8a91d30fde78cb69b94677cf1f"
-SRC_URI[archive.sha256sum] = "d296f318a74a6d7883358a6ce1c4d8808b7903dbbb4f9c61ab4230f18e6d7550"
+SRC_URI[archive.sha256sum] = "52f971e85140e5de74b9369ef6656e49ce95af1f232fc1e0df1f046129ab4f65"
+SRC_URI += "file://0001-Introduce-options-gjs_path-to-optionally-set-path-to.patch"
PACKAGECONFIG ??= "bluetooth nm ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
PACKAGECONFIG[bluetooth] = ",,gnome-bluetooth"
@@ -39,6 +39,9 @@ PACKAGECONFIG[nm] = "-Dnetworkmanager=true, -Dnetworkmanager=false, networkmanag
PACKAGECONFIG[systemd] = "-Dsystemd=true, -Dsystemd=false, systemd"
EXTRA_OEMESON = " \
+ -Dgjs_path=${bindir}/gjs \
+ -Dextensions-app:gjs_path=${bindir}/gjs \
+ -Dtests=false \
-Dman=false \
"
@@ -52,6 +55,7 @@ do_install:append() {
GSETTINGS_PACKAGE = "${PN}-gsettings"
FILES:${PN} += " \
+ ${datadir}/metainfo \
${datadir}/dbus-1 \
${datadir}/gnome-control-center \
${datadir}/xdg-desktop-portal \