aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <tim.orling@konsulko.com>2024-02-21 20:26:30 -0800
committerKhem Raj <raj.khem@gmail.com>2024-02-22 07:38:42 -0800
commit22f6e7eec394fcfbb84b48dd50c5bb90f1afb3f5 (patch)
tree7494b24b632f27e7ff8e7356bf1e2235c242b9d4
parentc558d137d438900519a68a542d1780edfb390fc9 (diff)
downloadmeta-openembedded-contrib-22f6e7eec394fcfbb84b48dd50c5bb90f1afb3f5.tar.gz
meta-perl-image-ptest: add PTESTS_PROBLEMS_META_PERL
In oe-core, PTESTS_PROBLEMS are also enabled, so even though the recipe might have failures or the ptests do not run cleanly, the BBCLASSEXTEND still works. Enable the same behavior for meta-perl. Signed-off-by: Tim Orling <tim.orling@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-perl/recipes-core/images/meta-perl-image-ptest-all.bb2
-rw-r--r--meta-perl/recipes-core/images/meta-perl-image-ptest.bb2
2 files changed, 2 insertions, 2 deletions
diff --git a/meta-perl/recipes-core/images/meta-perl-image-ptest-all.bb b/meta-perl/recipes-core/images/meta-perl-image-ptest-all.bb
index e2cafa98a5..9efe5087f0 100644
--- a/meta-perl/recipes-core/images/meta-perl-image-ptest-all.bb
+++ b/meta-perl/recipes-core/images/meta-perl-image-ptest-all.bb
@@ -9,7 +9,7 @@ REQUIRED_DISTRO_FEATURES = "ptest"
require conf/include/ptest-packagelists-meta-perl.inc
# Include the full set of ptests
-PTESTS_META_PERL = "${PTESTS_FAST_META_PERL} ${PTESTS_SLOW_META_PERL}"
+PTESTS_META_PERL = "${PTESTS_FAST_META_PERL} ${PTESTS_SLOW_META_PERL} ${PTESTS_PROBLEMS_META_PERL}"
do_testimage[noexec] = "1"
do_testimage[depends] = "${@' '.join(['meta-perl-image-ptest-'+x+':do_testimage' for x in d.getVar('PTESTS_META_PERL').split()])}"
diff --git a/meta-perl/recipes-core/images/meta-perl-image-ptest.bb b/meta-perl/recipes-core/images/meta-perl-image-ptest.bb
index 7905977828..94d77b97f0 100644
--- a/meta-perl/recipes-core/images/meta-perl-image-ptest.bb
+++ b/meta-perl/recipes-core/images/meta-perl-image-ptest.bb
@@ -9,7 +9,7 @@ require conf/include/ptest-packagelists-meta-perl.inc
DESCRIPTION += "Also including the ${MCNAME} ptest package."
HOMEPAGE = "https://www.openembedded.org/"
-PTESTS_META_PERL = "${PTESTS_SLOW_META_PERL} ${PTESTS_FAST_META_PERL}"
+PTESTS_META_PERL = "${PTESTS_SLOW_META_PERL} ${PTESTS_FAST_META_PERL} ${PTESTS_PROBLEMS_META_PERL}"
IMAGE_INSTALL:append = " ${MCNAME}-ptest openssh"