aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWindel Bouwman <windel.bouwman@gmail.com>2019-07-09 10:20:35 +0200
committerKhem Raj <raj.khem@gmail.com>2019-07-10 09:24:33 -0700
commitd650de0f777a4aae1a1d1bb5ed1dba984d1ddca3 (patch)
tree4a49218c09e515beaf7a4270e0d09f0a6202c17a
parentd25eea732cf2f8b5bac4f47d4f829caa72d62620 (diff)
downloadmeta-openembedded-contrib-d650de0f777a4aae1a1d1bb5ed1dba984d1ddca3.tar.gz
python-humanfriendly: Add recipe for the humanfriendly package.
Signed-off-by: Windel Bouwman <windel.bouwman@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python-humanfriendly.inc25
-rw-r--r--meta-python/recipes-devtools/python/python-humanfriendly_4.18.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-humanfriendly_4.18.bb2
3 files changed, 29 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-humanfriendly.inc b/meta-python/recipes-devtools/python/python-humanfriendly.inc
new file mode 100644
index 0000000000..94f7f8b813
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-humanfriendly.inc
@@ -0,0 +1,25 @@
+DESCRIPTION = "Human friendly output for text interfaces using Python"
+HOMEPAGE = "https://humanfriendly.readthedocs.io/"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=690da298a43805797a4fa7bbe180b3c6"
+
+PYPI_PACKAGE = "humanfriendly"
+
+SRC_URI[md5sum] = "9573f9f37a5454d8205cfd1b9b8db9d2"
+SRC_URI[sha256sum] = "33ee8ceb63f1db61cce8b5c800c531e1a61023ac5488ccde2ba574a85be00a85"
+
+inherit pypi
+
+RDEPENDS_${PN}_class-target += " \
+ ${PYTHON_PN}-datetime \
+ ${PYTHON_PN}-fcntl \
+ ${PYTHON_PN}-io \
+ ${PYTHON_PN}-logging \
+ ${PYTHON_PN}-math \
+ ${PYTHON_PN}-numbers \
+ ${PYTHON_PN}-shell \
+ ${PYTHON_PN}-stringold \
+"
+
+BBCLASSEXTEND = "native"
diff --git a/meta-python/recipes-devtools/python/python-humanfriendly_4.18.bb b/meta-python/recipes-devtools/python/python-humanfriendly_4.18.bb
new file mode 100644
index 0000000000..2ca5fe36f4
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-humanfriendly_4.18.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-humanfriendly.inc
diff --git a/meta-python/recipes-devtools/python/python3-humanfriendly_4.18.bb b/meta-python/recipes-devtools/python/python3-humanfriendly_4.18.bb
new file mode 100644
index 0000000000..2ca5fe36f4
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-humanfriendly_4.18.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-humanfriendly.inc