aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2016-05-05 16:03:45 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2016-05-06 12:40:27 +0200
commitfc1ee271f457ae2dd0ec50b4d2f8caf5b01a2cbe (patch)
tree9fd7896f84d19908f29ed4415f59fd0911c29578
parent2ff8e7e86aedb0ec3aaa1186e46aa145da1f379c (diff)
downloadmeta-openembedded-contrib-fc1ee271f457ae2dd0ec50b4d2f8caf5b01a2cbe.tar.gz
pidgin: add PACKAGECONFIGs
* disable gstreamer and vv, because gstreamer 0.10 is in meta-multimedia now * disable farsight2/farstream, because farsight2 is blacklisted * don't enable X11 support without x11 in DISTRO_FEATURES * allow to disable all UI, useful for DISTROs who want just the purple libraries like LuneOS Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-support/pidgin/pidgin_2.10.12.bb31
1 files changed, 23 insertions, 8 deletions
diff --git a/meta-oe/recipes-support/pidgin/pidgin_2.10.12.bb b/meta-oe/recipes-support/pidgin/pidgin_2.10.12.bb
index 9133c1ce29..ac0871fb4e 100644
--- a/meta-oe/recipes-support/pidgin/pidgin_2.10.12.bb
+++ b/meta-oe/recipes-support/pidgin/pidgin_2.10.12.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "multi-protocol instant messaging client"
SECTION = "x11/network"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
-DEPENDS = "python startup-notification avahi gtk+ ncurses gnutls virtual/libintl gstreamer dbus intltool-native farsight2 libidn libxml2 gconf dbus-glib"
+DEPENDS = "python virtual/libintl intltool-native libxml2 gconf"
inherit autotools gettext pkgconfig gconf perlnative
@@ -16,18 +16,33 @@ SRC_URI = "\
SRC_URI[md5sum] = "14e0f5cfb2ed065e4dc80391a806ac76"
SRC_URI[sha256sum] = "2c7523f0fefe89749c03b2b738ab9f7bd186da435be4762f1487eee31e77ffdd"
+PACKAGECONFIG ??= "gnutls consoleui avahi dbus idn \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11 gtk startup-notification', '', d)} \
+"
+PACKAGECONFIG[farsight2] = "--enable-farstream,--disable-farstream,farsight2"
+# --disable-gstreamer compile without GStreamer audio support
+# --disable-gstreamer-video
+# compile without GStreamer 1.0 Video Overlay support
+# --disable-gstreamer-interfaces
+# compile without GStreamer 0.10 interface support
+# --with-gstreamer=<version>
+# compile with GStreamer 0.10 or 1.0 interface
+PACKAGECONFIG[gstreamer] = "--enable-gstreamer,--disable-gstreamer,gstreamer"
+PACKAGECONFIG[vv] = "--enable-vv,--disable-vv,gstreamer"
+PACKAGECONFIG[idn] = "--enable-idn,--disable-idn,libidn"
+PACKAGECONFIG[gtk] = "--enable-gtkui,--disable-gtkui,gtk+"
+PACKAGECONFIG[x11] = "--with-x=yes --x-includes=${STAGING_INCDIR} --x-libraries=${STAGING_LIBDIR},--with-x=no,virtual/libx11"
+PACKAGECONFIG[startup-notification] = "--enable-startup-notification,--disable-startup-notification,startup-notification"
+PACKAGECONFIG[consoleui] = "--enable-consoleui --with-ncurses-headers=${STAGING_INCDIR},--disable-consoleui,ncurses"
+PACKAGECONFIG[gnutls] = "--enable-gnutls --with-gnutls-includes=${STAGING_INCDIR} --with-gnutls-libs=${STAGING_LIBDIR},--disable-gnutls,gnutls"
+PACKAGECONFIG[dbus] = "--enable-dbus,--disable-dbus,dbus dbus-glib"
+PACKAGECONFIG[avahi] = "--enable-avahi,--disable-avahi,avahi"
+
EXTRA_OECONF = " \
- --enable-vv \
--disable-perl \
--disable-tcl \
--disable-gevolution \
--disable-schemas-install \
- --x-includes=${STAGING_INCDIR} \
- --x-libraries=${STAGING_LIBDIR} \
- --enable-gnutls=yes \
- --with-ncurses-headers=${STAGING_INCDIR} \
- --with-gnutls-includes=${STAGING_INCDIR} \
- --with-gnutls-libs=${STAGING_LIBDIR} \
--disable-gtkspell \
--disable-meanwhile \
--disable-nm \