aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorQi.Chen@windriver.com <Qi.Chen@windriver.com>2016-05-04 13:43:19 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2016-05-06 12:40:26 +0200
commitbe3d4c05e3854c5c6d76c70609539ea8c5cc317b (patch)
tree535c916fd01e80d5e92ef2645b70f9cc74f67ce2
parentb957e27d13f723b467e05a77c0f6958c1d4815a8 (diff)
downloadmeta-openembedded-contrib-be3d4c05e3854c5c6d76c70609539ea8c5cc317b.tar.gz
meta-openembedded-contrib-be3d4c05e3854c5c6d76c70609539ea8c5cc317b.tar.bz2
meta-openembedded-contrib-be3d4c05e3854c5c6d76c70609539ea8c5cc317b.zip
rrdtool: fix do_configure failure on some hosts
On some hosts, when building rrdtool, we would meet do_configure error like below. | *** Module name IN: /usr/lib64/perl/5.22.0/POSIX.pm | *** p1: /usr/lib64/ p3: perl/5.22.0/ p5: POSIX.pm | *** Module name OUT: /path/to/builddir/tmp/sysroots/x86_64-linux/usr/lib/perl-native/perl/5.22.1/POSIX.pm | POSIX object version 1.53_01 does not match $POSIX::VERSION 1.53 at /usr/lib64/perl/5.22.0/XSLoader.pm line 108. Set PERLHOSTLIB to "" to fix the above error. Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-extended/rrdtool/rrdtool_1.5.4.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/rrdtool/rrdtool_1.5.4.bb b/meta-oe/recipes-extended/rrdtool/rrdtool_1.5.4.bb
index 4d6318cbde..216aafcee7 100644
--- a/meta-oe/recipes-extended/rrdtool/rrdtool_1.5.4.bb
+++ b/meta-oe/recipes-extended/rrdtool/rrdtool_1.5.4.bb
@@ -57,6 +57,8 @@ export STAGING_INCDIR
# emulate cpan_do_configure
EXTRA_OEMAKE = ' PERL5LIB="${PERL_ARCHLIB}" '
+# Avoid do_configure error on some hosts
+export PERLHOSTLIB = ""
do_configure() {
#fix the pkglib problem with newer automake