aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2016-05-05 16:32:53 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2016-05-06 12:40:28 +0200
commita6c172e2713f0018c5ebac0f957cff28b7ac2630 (patch)
tree6f2ccb3c4c1b4977c44df5b9b1763fcf1d3aab2d
parent9087a59b1c3f9708642a2327b0cf6ecceac0a66f (diff)
downloadmeta-openembedded-contrib-a6c172e2713f0018c5ebac0f957cff28b7ac2630.tar.gz
poppler: add --std=c++11 to fix build with Qt 5.7
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-support/poppler/poppler/0001-Compile-with-C-11-compilers-that-don-t-define-isinfi.patch39
-rw-r--r--meta-oe/recipes-support/poppler/poppler_0.41.0.bb4
2 files changed, 43 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/poppler/poppler/0001-Compile-with-C-11-compilers-that-don-t-define-isinfi.patch b/meta-oe/recipes-support/poppler/poppler/0001-Compile-with-C-11-compilers-that-don-t-define-isinfi.patch
new file mode 100644
index 0000000000..d5c34a6a02
--- /dev/null
+++ b/meta-oe/recipes-support/poppler/poppler/0001-Compile-with-C-11-compilers-that-don-t-define-isinfi.patch
@@ -0,0 +1,39 @@
+From a8e3399487258e53df0fd4a79c570c8d71188bed Mon Sep 17 00:00:00 2001
+From: Takahiro Hashimoto <kenya888.en@gmail.com>
+Date: Wed, 27 Apr 2016 00:16:52 +0200
+Subject: [PATCH] Compile with C++11 compilers that don't define isinfinite
+
+Bug #94761
+---
+ poppler/SplashOutputDev.cc | 8 ++++++++
+ 1 file changed, 8 insertions(+)
+
+diff --git a/poppler/SplashOutputDev.cc b/poppler/SplashOutputDev.cc
+index 13d090c..0e50702 100644
+--- a/poppler/SplashOutputDev.cc
++++ b/poppler/SplashOutputDev.cc
+@@ -36,6 +36,7 @@
+ // Copyright (C) 2014 Richard PALO <richard@netbsd.org>
+ // Copyright (C) 2015 Tamas Szekeres <szekerest@gmail.com>
+ // Copyright (C) 2015 Kenji Uno <ku@digitaldolphins.jp>
++// Copyright (C) 2016 Takahiro Hashimoto <kenya888.en@gmail.com>
+ //
+ // To see a description of the changes please see the Changelog file that
+ // came with your tarball or type make ChangeLog if you are building from git
+@@ -94,6 +95,13 @@ extern "C" int unlink(char *filename);
+ #endif
+ #endif
+
++#if __cplusplus > 199711L
++#include <cmath>
++#ifndef isfinite
++#define isfinite(x) std::isfinite(x)
++#endif
++#endif
++
+ static inline void convertGfxColor(SplashColorPtr dest,
+ SplashColorMode colorMode,
+ GfxColorSpace *colorSpace,
+--
+2.8.2
+
diff --git a/meta-oe/recipes-support/poppler/poppler_0.41.0.bb b/meta-oe/recipes-support/poppler/poppler_0.41.0.bb
index 4320408464..f7cc07681c 100644
--- a/meta-oe/recipes-support/poppler/poppler_0.41.0.bb
+++ b/meta-oe/recipes-support/poppler/poppler_0.41.0.bb
@@ -5,6 +5,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
SRC_URI = " \
http://poppler.freedesktop.org/${BP}.tar.xz \
file://0001-add-manadatory-options-to-find-qt4-qt5-moc.patch \
+ file://0001-Compile-with-C-11-compilers-that-don-t-define-isinfi.patch \
"
SRC_URI[md5sum] = "849a8bd6af5794efb961b70418414e5a"
SRC_URI[sha256sum] = "420abaab63caed9e1ee28964a0ba216d1979506726164bc99ad5ade289192a1b"
@@ -22,6 +23,9 @@ PACKAGECONFIG[openjpeg] = "--enable-libopenjpeg=openjpeg2,--disable-libopenjpeg,
PACKAGECONFIG[qt5] = "--enable-poppler-qt5 --with-moc-qt5=${STAGING_BINDIR_NATIVE}/qt5/moc,--disable-poppler-qt5,qtbase"
PACKAGECONFIG[qt4e] = "--enable-poppler-qt4 --with-moc-qt4=${STAGING_BINDIR_NATIVE}/moc4,--disable-poppler-qt4,qt4-embedded"
+# Needed for qt5
+CXXFLAGS += "--std=c++11"
+
EXTRA_OECONF = "\
--enable-xpdf-headers \
--disable-gtk-test \