aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoreu@felipetonello.com <eu@felipetonello.com>2016-05-03 16:20:24 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2016-05-06 12:40:26 +0200
commit821414a07d435f9dd797e3ba09cd49d495a9d460 (patch)
tree78a71d82bb3d23bcff3bbfa724947398c8f5bc50
parent3bae88a2ee7befdd5bff6e7002c5407f94eb720d (diff)
downloadmeta-openembedded-contrib-821414a07d435f9dd797e3ba09cd49d495a9d460.tar.gz
protobuf: split package to main and compiler packages
Protobuf has two main features, a compiler and a library. Run-time applications only need the libraries to run. Signed-off-by: Felipe F. Tonello <eu@felipetonello.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-devtools/protobuf/protobuf_2.6.1.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/protobuf/protobuf_2.6.1.bb b/meta-oe/recipes-devtools/protobuf/protobuf_2.6.1.bb
index 049f9d4e8f..2977c59c4b 100644
--- a/meta-oe/recipes-devtools/protobuf/protobuf_2.6.1.bb
+++ b/meta-oe/recipes-devtools/protobuf/protobuf_2.6.1.bb
@@ -6,7 +6,11 @@ HOMEPAGE = "https://github.com/google/protobuf"
SECTION = "console/tools"
LICENSE = "BSD-3-Clause"
+PACKAGE_BEFORE_PN = "${PN}-compiler"
+
DEPENDS = "zlib"
+RDEPENDS_${PN}-compiler = "${PN}"
+RDEPENDS_${PN}-dev += "${PN}-compiler"
LIC_FILES_CHKSUM = "file://LICENSE;md5=af6809583bfde9a31595a58bb4a24514"
@@ -22,4 +26,6 @@ inherit autotools
S = "${WORKDIR}/git"
+FILES_${PN}-compiler = "${bindir} ${libdir}/libprotoc${SOLIBS}"
+
BBCLASSEXTEND = "native nativesdk"