aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKinsella, Ray <ray.kinsella@intel.com>2016-05-06 14:49:19 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2016-05-10 20:18:56 +0200
commit786ab843f0eb825781df5b4c639b6ae5f4c74c41 (patch)
tree84570b0cb0b614d38e534b74c2030ccd838ff415
parent102e6998645b0ce4d80dee5dab500df34eab8640 (diff)
downloadmeta-openembedded-contrib-786ab843f0eb825781df5b4c639b6ae5f4c74c41.tar.gz
wvstreams: fixing segfault with new gcc optimizations
Recent GCC optimizations -ftree-dce and -foptimize-sibling-calls are causing a segfault in the wvstream stackmaster. Fedora had the same problem and resolved the issue by removing these optimizations. See: https://bugzilla.redhat.com/show_bug.cgi?id=812651 Signed-off-by: Ray Kinsella <ray.kinsella@intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-connectivity/wvdial/wvstreams_4.6.1.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/wvdial/wvstreams_4.6.1.bb b/meta-oe/recipes-connectivity/wvdial/wvstreams_4.6.1.bb
index 73cfb03565..6199a2f7ec 100644
--- a/meta-oe/recipes-connectivity/wvdial/wvstreams_4.6.1.bb
+++ b/meta-oe/recipes-connectivity/wvdial/wvstreams_4.6.1.bb
@@ -20,6 +20,8 @@ inherit autotools-brokensep pkgconfig
PARALLEL_MAKE = ""
+TARGET_CFLAGS_append = " -fno-tree-dce -fno-optimize-sibling-calls"
+
LDFLAGS_append = " -Wl,-rpath-link,${CROSS_DIR}/${TARGET_SYS}/lib"
EXTRA_OECONF = " --without-tcl --without-qt --without-pam --without-valgrind"