aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2016-04-26 15:08:42 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2016-04-28 10:38:56 +0200
commit6fbaf07c2b41ef833a91fe016864d0d1a3815d88 (patch)
tree3ebe96dde40fe4efeb5b52575aecc97b3f496dd7
parentb5a7dfbea5de5315eb09235e6dcd4930fcc467da (diff)
downloadmeta-openembedded-contrib-6fbaf07c2b41ef833a91fe016864d0d1a3815d88.tar.gz
mozjs: fix configure host contamination
When building mozjs the following error was observed | Traceback (most recent call last): | File "./config.status", line 9, in <module> | from ConfigStatus import config_status | File "/build/bitbake_build/tmp/work/corei7-64-wrs-linux/mozjs/17.0.0-r0/mozjs17.0.0/js/src/build/ConfigStatus.py", line 11, in <module> | import sys, re, os, posixpath, ntpath | File "/usr/lib/python2.7/ntpath.py", line 15, in <module> | from genericpath import _unicode | ImportError: cannot import name _unicode | WARNING: exit code 1 from a shell command. | ERROR: Function failed: do_configure (log file is located at /build//bitbake_build/tmp/work/corei7-64-wrs-linux/mozjs/17.0.0-r0/temp/do_configure/log.do_configure.1056 Note the host paths found in the error msg. Further this issue can be explored using the host python, which will not error when attempting the above import, and the python in the sysroot, which will fail when we attempt the import. By inheriting pythonnative we ensure the proper paths are set to avoid this host contamination. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-extended/mozjs/mozjs_17.0.0.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-oe/recipes-extended/mozjs/mozjs_17.0.0.bb b/meta-oe/recipes-extended/mozjs/mozjs_17.0.0.bb
index da0578914f..02d56942fa 100644
--- a/meta-oe/recipes-extended/mozjs/mozjs_17.0.0.bb
+++ b/meta-oe/recipes-extended/mozjs/mozjs_17.0.0.bb
@@ -22,7 +22,7 @@ SRC_URI[sha256sum] = "321e964fe9386785d3bf80870640f2fa1c683e32fe988eeb201b04471c
S = "${WORKDIR}/${BPN}${PV}/js/src"
-inherit autotools pkgconfig perlnative
+inherit autotools pkgconfig perlnative pythonnative
DEPENDS += "nspr zlib"