aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2016-04-06 22:19:30 +0100
committerRoss Burton <ross.burton@intel.com>2016-05-17 16:48:36 +0100
commit2c2578316d6b3e1ee7940e2a5779f9ad503b0ffd (patch)
tree8e82f692c1ceedb3454a5e0aacf9bce2d17c1eb7
parent37297c3222a40b916d98ccd06b757b595aebc756 (diff)
downloadmeta-openembedded-contrib-2c2578316d6b3e1ee7940e2a5779f9ad503b0ffd.tar.gz
libverto: add new recipe
libverto is an event-loop agnostic asynchronous API library. Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta-oe/recipes-support/libverto/libverto_0.2.6.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/libverto/libverto_0.2.6.bb b/meta-oe/recipes-support/libverto/libverto_0.2.6.bb
new file mode 100644
index 0000000000..bec773db8a
--- /dev/null
+++ b/meta-oe/recipes-support/libverto/libverto_0.2.6.bb
@@ -0,0 +1,23 @@
+SUMMARY = "event-loop neutral asynchronous API"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=bc8917ab981cfa6161dc29319a4038d9"
+
+SRC_URI = "https://fedorahosted.org/releases/l/i/libverto/libverto-${PV}.tar.gz"
+SRC_URI[md5sum] = "d4e81c21403031089d71eaab07708b89"
+SRC_URI[sha256sum] = "17eca6a3855f4884e2e7095e91501767d834b3bf313a6f59a93303f54ac91c9e"
+
+inherit autotools pkgconfig
+
+PACKAGES_DYNAMIC += "^libverto-.*"
+
+EXTRA_OECONF = "--with-pthread"
+
+PACKAGECONFIG ??= "glib libevent"
+PACKAGECONFIG[glib] = "--with-glib=default,--without-glib,glib-2.0"
+PACKAGECONFIG[libev] = "--with-libev=default,--without-libev,libev"
+PACKAGECONFIG[libevent] = "--with-libevent=default,--without-libevent,libevent"
+PACKAGECONFIG[tevent] = "--with-tevent=default,--without-tevent,libtevent"
+
+python populate_packages_prepend () {
+ do_split_packages(d, "${libdir}", "^libverto-(.*)\.so\..*$", "libverto-%s", "libverto module for %s", allow_links=True, prepend=True)
+}