aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorIoan-Adrian Ratiu <adrian.ratiu@ni.com>2016-04-29 15:38:50 +0300
committerMartin Jansa <Martin.Jansa@gmail.com>2016-05-06 12:40:22 +0200
commit03071511d5e2a50e7bd6507a57d876b97a81bb4d (patch)
treeba6eebac71d93c99073629595e7a88514e882a58
parent1bd027eba40546dcf1eaa02c518cad3c0495b34f (diff)
downloadmeta-openembedded-contrib-03071511d5e2a50e7bd6507a57d876b97a81bb4d.tar.gz
syslog-ng.inc: fix prerm script & class includes
The order of class includes is very important because it's the order in which classes are evaluated. Both update-rc.d and update-alternatives write to the prerm script, so the class order decides the script code ordering. As they are now, prerm is: #!/bin/sh update-alternatives --remove syslog-init /etc/init.d/syslog.syslog-ng if [ -z "$D" ]; then /etc/init.d/syslog stop fi This causes errors because when syslog-ng is the only alternative it is removed and then the script tries to stop it (No such file or directory) but even if there are other alternatives, the script tries to stop something other than syslog-ng which was removed. By reversing the include order, prerm gets generated correctly and it tries to stop syslog-ng before removing it: if [ -z "$D" ]; then /etc/init.d/syslog stop fi update-alternatives --remove syslog-init /etc/init.d/syslog.syslog-ng Signed-off-by: Ioan-Adrian Ratiu <adrian.ratiu@ni.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-support/syslog-ng/syslog-ng.inc2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/syslog-ng/syslog-ng.inc b/meta-oe/recipes-support/syslog-ng/syslog-ng.inc
index 382dc5e30f..4e0f697bce 100644
--- a/meta-oe/recipes-support/syslog-ng/syslog-ng.inc
+++ b/meta-oe/recipes-support/syslog-ng/syslog-ng.inc
@@ -22,7 +22,7 @@ SRC_URI = "http://www.balabit.com/downloads/files/syslog-ng/sources/${PV}/source
file://configure.ac-add-option-enable-thread-tls-to-manage-.patch \
"
-inherit autotools systemd pkgconfig update-rc.d update-alternatives
+inherit autotools systemd pkgconfig update-alternatives update-rc.d
EXTRA_OECONF = " \
--enable-dynamic-linking \