aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2018-07-02 17:50:05 +0100
committerRoss Burton <ross.burton@intel.com>2018-07-03 10:20:03 +0100
commiteda7e24eeacfec2e3246c655b8a208c7861cfd91 (patch)
tree6786111e924eaee9db4201c31a1c5e7b95b3f9a9
parent209dffc4c6ece50bf6f7f551523f6f871656f694 (diff)
downloadmeta-openembedded-contrib-eda7e24eeacfec2e3246c655b8a208c7861cfd91.tar.gz
p7zip: simplify recipe
The plugin-based 7z binary is mostly useless because it can't find the libraries. Simply just install 7za, and install a compatibility symlink for 7z. Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta-oe/recipes-extended/p7zip/p7zip_16.02.bb23
1 files changed, 3 insertions, 20 deletions
diff --git a/meta-oe/recipes-extended/p7zip/p7zip_16.02.bb b/meta-oe/recipes-extended/p7zip/p7zip_16.02.bb
index d986da9043..13479a90fe 100644
--- a/meta-oe/recipes-extended/p7zip/p7zip_16.02.bb
+++ b/meta-oe/recipes-extended/p7zip/p7zip_16.02.bb
@@ -17,26 +17,9 @@ SRC_URI[sha256sum] = "5eb20ac0e2944f6cb9c2d51dd6c4518941c185347d4089ea89087ffdd6
S = "${WORKDIR}/${BPN}_${PV}"
do_install() {
- install -d ${D}${bindir}
- install -m 0755 ${S}/bin/* ${D}${bindir}
-}
-
-# all3: to build bin/7za, bin/7z (with its plugins), bin/7zr and bin/7zCon.sfx
-EXTRA_OEMAKE_class-native = "all3"
-
-do_install_class-native() {
- install -d ${D}${bindir}
- install -d ${D}${bindir}/Codecs
- install -m 0755 ${S}/bin/7* ${D}${bindir}
- install -m 0755 ${S}/bin/Codecs/* ${D}${bindir}/Codecs
-
- # Create a shell script wrapper to execute next to 7z.so
- mv ${D}${bindir}/7z ${D}${bindir}/7z.bin
- cat > ${D}${bindir}/7z << 'EOF'
-#!/bin/sh
-exec "$(dirname "$0")"/7z.bin "$@"
-EOF
- chmod 0755 ${D}${bindir}/7z
+ install -d ${D}${bindir}
+ install -m 0755 ${S}/bin/* ${D}${bindir}
+ ln -s 7za ${D}${bindir}/7z
}
BBCLASSEXTEND = "native"