aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2019-07-09 21:30:59 -0400
committerKhem Raj <raj.khem@gmail.com>2019-07-10 09:28:20 -0700
commitec273fe1e41e839592b11d61189e5777d2f821ca (patch)
treee71943b25ea096558eb9c1f1c8c9cc6db42876f5
parent583ffd416c17fba04345d9ba6cad1001e1509eb6 (diff)
downloadmeta-openembedded-contrib-ec273fe1e41e839592b11d61189e5777d2f821ca.tar.gz
python3-blivetgui: fix blivet-gui broken
In target installer anaconda 30, when they try to go to blivet-gui, anaconda.log shows a traceback: 23:02:49,842 INF threading: Thread Done: AnaExecuteStorageThread (140274838624000) 23:02:49,844 DBG exception: running handleException 23:02:49,845 CRT exception: Traceback (most recent call last): File "/usr/lib/python3.7/site-packages/blivetgui/list_devices.py", line 165, in on_disk_selection_changed selection.select_iter(self.last_iter) TypeError: Argument 1 does not allow None as a value 23:02:49,845 DBG exception: Gtk running, queuing exception handler to the main loop 23:02:49,858 DBG ui.common: Entered spoke: BlivetGuiSpoke 23:02:49,858 DBG exception: running handleException 23:02:49,859 CRT exception: Traceback (most recent call last): File "/usr/lib/python3.7/site-packages/blivetgui/list_devices.py", line 165, in on_disk_selection_changed selection.select_iter(self.last_iter) TypeError: Argument 1 does not allow None as a value Backport a patch from upstream could fix the issue Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-extended/python-blivet/python3-blivetgui/0001-Fix-return-type-of-BlivetUtils.get_disks-1658893.patch32
-rw-r--r--meta-python/recipes-extended/python-blivet/python3-blivetgui_2.1.10.bb1
2 files changed, 33 insertions, 0 deletions
diff --git a/meta-python/recipes-extended/python-blivet/python3-blivetgui/0001-Fix-return-type-of-BlivetUtils.get_disks-1658893.patch b/meta-python/recipes-extended/python-blivet/python3-blivetgui/0001-Fix-return-type-of-BlivetUtils.get_disks-1658893.patch
new file mode 100644
index 0000000000..cf80566854
--- /dev/null
+++ b/meta-python/recipes-extended/python-blivet/python3-blivetgui/0001-Fix-return-type-of-BlivetUtils.get_disks-1658893.patch
@@ -0,0 +1,32 @@
+From 4d0f9f961704bc1dd83fdf6808fb6ab91dc6a768 Mon Sep 17 00:00:00 2001
+From: Vojtech Trefny <vtrefny@redhat.com>
+Date: Thu, 13 Dec 2018 13:39:03 +0100
+Subject: [PATCH] Fix return type of BlivetUtils.get_disks (#1658893)
+
+This must be a list, not a generator, because we are iterating
+over it multiple times in some cases.
+
+Upstream-Status: Backport[git://github.com/rhinstaller/blivet-gui]
+
+Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
+
+---
+ blivetgui/blivet_utils.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/blivetgui/blivet_utils.py b/blivetgui/blivet_utils.py
+index e2bd802..ddb04fc 100644
+--- a/blivetgui/blivet_utils.py
++++ b/blivetgui/blivet_utils.py
+@@ -204,7 +204,7 @@ class BlivetUtils(object):
+
+ """
+
+- return (device for device in self.storage.disks if device.type != "mdarray")
++ return [device for device in self.storage.disks if device.type != "mdarray"]
+
+ def get_group_devices(self):
+ """ Return list of LVM2 Volume Group devices
+--
+2.7.4
+
diff --git a/meta-python/recipes-extended/python-blivet/python3-blivetgui_2.1.10.bb b/meta-python/recipes-extended/python-blivet/python3-blivetgui_2.1.10.bb
index 2ea810327d..b7e2493c32 100644
--- a/meta-python/recipes-extended/python-blivet/python3-blivetgui_2.1.10.bb
+++ b/meta-python/recipes-extended/python-blivet/python3-blivetgui_2.1.10.bb
@@ -10,6 +10,7 @@ B = "${S}"
SRCREV = "67ec0b7a0e065ba24ab87963409bfb21b2aac6dd"
SRC_URI = "git://github.com/rhinstaller/blivet-gui;branch=master \
+ file://0001-Fix-return-type-of-BlivetUtils.get_disks-1658893.patch \
"
inherit distro_features_check