aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@arm.com>2022-03-08 22:16:11 +0000
committerRoss Burton <ross.burton@arm.com>2022-03-08 22:59:55 +0000
commitd8f27e384745c25d20cf4f4a5b5e7bbe1b6cd6a9 (patch)
tree1df3ef05c5d902641e66f0f97a787dc10bf6fb67
parent22a9d92cea1665bfefd2c7060b6ae33bbc76a83e (diff)
downloadmeta-openembedded-contrib-d8f27e384745c25d20cf4f4a5b5e7bbe1b6cd6a9.tar.gz
set proper build ssytem
-rw-r--r--meta-python/recipes-devtools/python/python3-ansi2html_1.7.0.bb7
-rw-r--r--meta-python/recipes-devtools/python/python3-asttokens_2.0.5.bb7
-rw-r--r--meta-python/recipes-devtools/python/python3-bidict_0.21.4.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-cachetools_4.2.4.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-fasteners_0.17.3.bb7
-rw-r--r--meta-python/recipes-devtools/python/python3-flask-migrate_3.1.0.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-flask-socketio_5.1.1.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-humanize_4.0.0.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-hyperlink_21.0.0.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-iso3166_2.0.2.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-license-expression_21.6.14.bb7
-rw-r--r--meta-python/recipes-devtools/python/python3-mypy_0.910.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-ordered-set_4.1.0.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-pynacl_1.5.0.bb3
-rw-r--r--meta-python/recipes-devtools/python/python3-pyrad_2.4.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-pyscaffold_4.1.5.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-pytest-forked_1.4.0.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-pytest-helpers-namespace_2021.4.29.bb12
-rw-r--r--meta-python/recipes-devtools/python/python3-pytest-html_3.1.1.bb3
-rw-r--r--meta-python/recipes-devtools/python/python3-pytest-runner_5.3.1.bb4
-rw-r--r--meta-python/recipes-devtools/python/python3-pytest-xdist_2.5.0.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-simpleeval_0.9.12.bb6
-rw-r--r--meta-python/recipes-devtools/python/python3-soupsieve_2.3.1.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-tqdm_4.63.0.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-twine_3.8.0.bb7
-rw-r--r--meta-python/recipes-devtools/python/python3-waitress_2.1.0.bb2
26 files changed, 29 insertions, 66 deletions
diff --git a/meta-python/recipes-devtools/python/python3-ansi2html_1.7.0.bb b/meta-python/recipes-devtools/python/python3-ansi2html_1.7.0.bb
index 0a81ebdded..9a6e0f7a3a 100644
--- a/meta-python/recipes-devtools/python/python3-ansi2html_1.7.0.bb
+++ b/meta-python/recipes-devtools/python/python3-ansi2html_1.7.0.bb
@@ -7,7 +7,7 @@ PYPI_PACKAGE = "ansi2html"
SRC_URI[sha256sum] = "69316be8c68ac91c5582d397c2890e69c993cc7cda52062ac7e45fcb660d8edc"
-inherit pypi setuptools3
+inherit pypi setuptools_build_meta
DEPENDS += " \
${PYTHON_PN}-setuptools-scm-native \
@@ -18,8 +18,3 @@ RDEPENDS:${PN} = " \
${PYTHON_PN}-six \
${PYTHON_PN}-compression \
"
-
-do_compile:prepend() {
- echo "from setuptools import setup" > ${S}/setup.py
- echo "setup()" >> ${S}/setup.py
-}
diff --git a/meta-python/recipes-devtools/python/python3-asttokens_2.0.5.bb b/meta-python/recipes-devtools/python/python3-asttokens_2.0.5.bb
index 429a56bae6..d45e70ce8a 100644
--- a/meta-python/recipes-devtools/python/python3-asttokens_2.0.5.bb
+++ b/meta-python/recipes-devtools/python/python3-asttokens_2.0.5.bb
@@ -5,13 +5,10 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
PYPI_PACKAGE = "asttokens"
-inherit pypi setuptools3
+inherit pypi setuptools_build_meta
SRC_URI[sha256sum] = "9a54c114f02c7a9480d56550932546a3f1fe71d8a02f1bc7ccd0ee3ee35cf4d5"
-DEPENDS += "\
- python3-setuptools-scm-native \
- python3-wheel-native \
-"
+DEPENDS += "python3-setuptools-scm-native"
BBCLASSEXTEND = "native"
diff --git a/meta-python/recipes-devtools/python/python3-bidict_0.21.4.bb b/meta-python/recipes-devtools/python/python3-bidict_0.21.4.bb
index 266dc606a2..95426a4ae7 100644
--- a/meta-python/recipes-devtools/python/python3-bidict_0.21.4.bb
+++ b/meta-python/recipes-devtools/python/python3-bidict_0.21.4.bb
@@ -6,6 +6,6 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=9741c346eef56131163e13b9db1241b3"
SRC_URI[sha256sum] = "42c84ffbe6f8de898af6073b4be9ea7ccedcd78d3474aa844c54e49d5a079f6f"
-inherit pypi setuptools3
+inherit pypi setuptools_build_meta
DEPENDS += "python3-setuptools-scm-native"
diff --git a/meta-python/recipes-devtools/python/python3-cachetools_4.2.4.bb b/meta-python/recipes-devtools/python/python3-cachetools_4.2.4.bb
index 1040dc7e5a..060a615d0b 100644
--- a/meta-python/recipes-devtools/python/python3-cachetools_4.2.4.bb
+++ b/meta-python/recipes-devtools/python/python3-cachetools_4.2.4.bb
@@ -8,7 +8,7 @@ SECTION = "devel/python"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=439a07e400525964c3c82684146e46eb"
-inherit pypi setuptools3 ptest
+inherit pypi setuptools_build_meta ptest
SRC_URI += " \
file://run-ptest \
diff --git a/meta-python/recipes-devtools/python/python3-fasteners_0.17.3.bb b/meta-python/recipes-devtools/python/python3-fasteners_0.17.3.bb
index d672708776..9baf23b7c0 100644
--- a/meta-python/recipes-devtools/python/python3-fasteners_0.17.3.bb
+++ b/meta-python/recipes-devtools/python/python3-fasteners_0.17.3.bb
@@ -5,14 +5,9 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=4476c4be31402271e101d9a4a3430d52"
SRC_URI[sha256sum] = "a9a42a208573d4074c77d041447336cf4e3c1389a256fd3e113ef59cf29b7980"
-inherit pypi setuptools3
+inherit pypi setuptools_build_meta
RDEPENDS:${PN} += "\
${PYTHON_PN}-logging \
${PYTHON_PN}-fcntl \
"
-
-do_compile:prepend() {
- echo "from setuptools import setup" > ${S}/setup.py
- echo "setup()" >> ${S}/setup.py
-}
diff --git a/meta-python/recipes-devtools/python/python3-flask-migrate_3.1.0.bb b/meta-python/recipes-devtools/python/python3-flask-migrate_3.1.0.bb
index 7a7c3fa3f3..b6e565f471 100644
--- a/meta-python/recipes-devtools/python/python3-flask-migrate_3.1.0.bb
+++ b/meta-python/recipes-devtools/python/python3-flask-migrate_3.1.0.bb
@@ -6,7 +6,7 @@ SRC_URI[sha256sum] = "57d6060839e3a7f150eaab6fe4e726d9e3e7cffe2150fb223d73f92421
PYPI_PACKAGE = "Flask-Migrate"
-inherit pypi setuptools3
+inherit pypi setuptools_build_meta
RDEPENDS:${PN} += "\
${PYTHON_PN}-flask-sqlalchemy \
diff --git a/meta-python/recipes-devtools/python/python3-flask-socketio_5.1.1.bb b/meta-python/recipes-devtools/python/python3-flask-socketio_5.1.1.bb
index 3d7a1cb6a8..b854ce7f72 100644
--- a/meta-python/recipes-devtools/python/python3-flask-socketio_5.1.1.bb
+++ b/meta-python/recipes-devtools/python/python3-flask-socketio_5.1.1.bb
@@ -5,7 +5,7 @@ SECTION = "devel/python"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=38cc21254909604298ce763a6e4440a0"
-inherit pypi setuptools3
+inherit pypi setuptools_build_meta
PYPI_PACKAGE = "Flask-SocketIO"
diff --git a/meta-python/recipes-devtools/python/python3-humanize_4.0.0.bb b/meta-python/recipes-devtools/python/python3-humanize_4.0.0.bb
index f84034f3cd..5d6a6c9d08 100644
--- a/meta-python/recipes-devtools/python/python3-humanize_4.0.0.bb
+++ b/meta-python/recipes-devtools/python/python3-humanize_4.0.0.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://LICENCE;md5=4ecc42519e84f6f3e23529464df7bd1d"
SRC_URI[sha256sum] = "ee1f872fdfc7d2ef4a28d4f80ddde9f96d36955b5d6b0dac4bdeb99502bddb00"
-inherit pypi setuptools3
+inherit pypi setuptools_build_meta
DEPENDS += "\
${PYTHON_PN}-setuptools-scm-native \
diff --git a/meta-python/recipes-devtools/python/python3-hyperlink_21.0.0.bb b/meta-python/recipes-devtools/python/python3-hyperlink_21.0.0.bb
index e9bf92aa1a..7be4b66a85 100644
--- a/meta-python/recipes-devtools/python/python3-hyperlink_21.0.0.bb
+++ b/meta-python/recipes-devtools/python/python3-hyperlink_21.0.0.bb
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=6dc5b4bd3d02faedf08461621aa2aeca"
SRC_URI[sha256sum] = "427af957daa58bc909471c6c40f74c5450fa123dd093fc53efd2e91d2705a56b"
-inherit pypi setuptools3
+inherit pypi setuptools_build_meta
RDEPENDS:${PN} += "${PYTHON_PN}-stringold ${PYTHON_PN}-netclient ${PYTHON_PN}-idna"
diff --git a/meta-python/recipes-devtools/python/python3-iso3166_2.0.2.bb b/meta-python/recipes-devtools/python/python3-iso3166_2.0.2.bb
index bc05f066a6..f3ef467f4b 100644
--- a/meta-python/recipes-devtools/python/python3-iso3166_2.0.2.bb
+++ b/meta-python/recipes-devtools/python/python3-iso3166_2.0.2.bb
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=5e2f4edc7e7408a82e4a1d05f229b695"
SRC_URI[sha256sum] = "04d02cfcfc18a6f8a9a4edb4d0a55e2e4fc575626c29d702f750de415e88d372"
-inherit pypi setuptools3 ptest
+inherit pypi setuptools_build_meta ptest
SRC_URI += " \
file://run-ptest \
diff --git a/meta-python/recipes-devtools/python/python3-license-expression_21.6.14.bb b/meta-python/recipes-devtools/python/python3-license-expression_21.6.14.bb
index efa8854411..01a5a94e1a 100644
--- a/meta-python/recipes-devtools/python/python3-license-expression_21.6.14.bb
+++ b/meta-python/recipes-devtools/python/python3-license-expression_21.6.14.bb
@@ -6,12 +6,9 @@ LIC_FILES_CHKSUM = "file://apache-2.0.LICENSE;md5=9429839cdc4b292ff46e88b524c6e0
SRC_URI[sha256sum] = "9de87a427c9a449eee7913472fb9ed03b63036295547369fdbf95f76a8b924b2"
-inherit pypi ptest setuptools3
+inherit pypi ptest setuptools_build_meta
-DEPENDS += "\
- ${PYTHON_PN}-setuptools-scm-native \
- ${PYTHON_PN}-wheel-native \
-"
+DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
RDEPENDS:${PN} += "\
${PYTHON_PN}-booleanpy \
diff --git a/meta-python/recipes-devtools/python/python3-mypy_0.910.bb b/meta-python/recipes-devtools/python/python3-mypy_0.910.bb
index 1a494af5af..be9ad3f66a 100644
--- a/meta-python/recipes-devtools/python/python3-mypy_0.910.bb
+++ b/meta-python/recipes-devtools/python/python3-mypy_0.910.bb
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=17b7180fcfc43c4e70c07c71588604c4"
PYPI_PACKAGE = "mypy"
-inherit pypi setuptools3
+inherit pypi setuptools_build_meta
SRC_URI[sha256sum] = "704098302473cb31a218f1775a873b376b30b4c18229421e9e9dc8916fd16150"
diff --git a/meta-python/recipes-devtools/python/python3-ordered-set_4.1.0.bb b/meta-python/recipes-devtools/python/python3-ordered-set_4.1.0.bb
index 2740b33551..b3600d093a 100644
--- a/meta-python/recipes-devtools/python/python3-ordered-set_4.1.0.bb
+++ b/meta-python/recipes-devtools/python/python3-ordered-set_4.1.0.bb
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://MIT-LICENSE;md5=3bf5e1ad64c0d99032c3143361fa234e"
SRC_URI[sha256sum] = "694a8e44c87657c59292ede72891eb91d34131f6531463aab3009191c77364a8"
-inherit pypi setuptools3 ptest
+inherit pypi flit_core ptest
DEPENDS += "python3-pytest-runner-native"
diff --git a/meta-python/recipes-devtools/python/python3-pynacl_1.5.0.bb b/meta-python/recipes-devtools/python/python3-pynacl_1.5.0.bb
index 10f624b484..fd27c62d15 100644
--- a/meta-python/recipes-devtools/python/python3-pynacl_1.5.0.bb
+++ b/meta-python/recipes-devtools/python/python3-pynacl_1.5.0.bb
@@ -8,10 +8,9 @@ SRC_URI[sha256sum] = "8ac7448f09ab85811607bdd21ec2464495ac8b7c66d146bf545b0f08fb
PYPI_PACKAGE = "PyNaCl"
-inherit pypi setuptools3
+inherit pypi setuptools_build_meta
DEPENDS += "\
- ${PYTHON_PN}-wheel-native \
${PYTHON_PN}-cffi-native \
libsodium \
"
diff --git a/meta-python/recipes-devtools/python/python3-pyrad_2.4.bb b/meta-python/recipes-devtools/python/python3-pyrad_2.4.bb
index 86a95a4aa4..665aaf38bd 100644
--- a/meta-python/recipes-devtools/python/python3-pyrad_2.4.bb
+++ b/meta-python/recipes-devtools/python/python3-pyrad_2.4.bb
@@ -6,4 +6,4 @@ LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=e910b35b0ef4e1f665
PYPI_PACKAGE = "pyrad"
SRC_URI[sha256sum] = "057de4b7e89d8da57ba782c1bde45c63ebee720ae2c0b0a69beaff15c47e30d9"
-inherit pypi setuptools3
+inherit pypi poetry_core
diff --git a/meta-python/recipes-devtools/python/python3-pyscaffold_4.1.5.bb b/meta-python/recipes-devtools/python/python3-pyscaffold_4.1.5.bb
index cd160a69eb..9cf876ae36 100644
--- a/meta-python/recipes-devtools/python/python3-pyscaffold_4.1.5.bb
+++ b/meta-python/recipes-devtools/python/python3-pyscaffold_4.1.5.bb
@@ -11,7 +11,7 @@ DEPENDS += "python3-setuptools-scm-native"
SRC_URI[sha256sum] = "55f6532fd6d62b3b698d604257f7a7eda6a87557bbec22760f8c0d9549454802"
-inherit pypi setuptools3
+inherit pypi setuptools_build_meta
PYPI_PACKAGE = "PyScaffold"
RDEPENDS:${PN} += " \
diff --git a/meta-python/recipes-devtools/python/python3-pytest-forked_1.4.0.bb b/meta-python/recipes-devtools/python/python3-pytest-forked_1.4.0.bb
index c6f352bc61..d75dd401d1 100644
--- a/meta-python/recipes-devtools/python/python3-pytest-forked_1.4.0.bb
+++ b/meta-python/recipes-devtools/python/python3-pytest-forked_1.4.0.bb
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=772fcdaca14b378878d05c7d857e6c3e"
SRC_URI[sha256sum] = "8b67587c8f98cbbadfdd804539ed5455b6ed03802203485dd2f53c1422d7440e"
-inherit pypi setuptools3
+inherit pypi setuptools_build_meta
DEPENDS += "python3-setuptools-scm-native"
diff --git a/meta-python/recipes-devtools/python/python3-pytest-helpers-namespace_2021.4.29.bb b/meta-python/recipes-devtools/python/python3-pytest-helpers-namespace_2021.4.29.bb
index 0ee1bd6866..6ccf365f43 100644
--- a/meta-python/recipes-devtools/python/python3-pytest-helpers-namespace_2021.4.29.bb
+++ b/meta-python/recipes-devtools/python/python3-pytest-helpers-namespace_2021.4.29.bb
@@ -6,17 +6,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=440a4cdb311cd7ad181efb4cba06d562"
SRC_URI[sha256sum] = "183524e3db4e2a1fea92e0ca3662a624ba44c9f3568da15679d7535ba6838a6a"
-inherit pypi setuptools3
-
-# Workaround for network access issue during compile step
-# this needs to be fixed in the recipes buildsystem to move
-# this such that it can be accomplished during do_fetch task
-do_compile[network] = "1"
-
-DEPENDS += "\
- ${PYTHON_PN}-wheel-native \
- ${PYTHON_PN}-pip-native \
-"
+inherit pypi setuptools_build_meta
RDEPENDS:${PN} += " \
${PYTHON_PN}-pytest \
diff --git a/meta-python/recipes-devtools/python/python3-pytest-html_3.1.1.bb b/meta-python/recipes-devtools/python/python3-pytest-html_3.1.1.bb
index cd0450f519..4b4aff01ce 100644
--- a/meta-python/recipes-devtools/python/python3-pytest-html_3.1.1.bb
+++ b/meta-python/recipes-devtools/python/python3-pytest-html_3.1.1.bb
@@ -6,10 +6,9 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=5d425c8f3157dbf212db2ec53d9e5132"
SRC_URI[sha256sum] = "3ee1cf319c913d19fe53aeb0bc400e7b0bc2dbeb477553733db1dad12eb75ee3"
-
PYPI_PACKAGE = "pytest-html"
-inherit pypi setuptools3
+inherit pypi setuptools_build_meta
RDEPENDS:${PN} += " \
${PYTHON_PN}-pytest \
diff --git a/meta-python/recipes-devtools/python/python3-pytest-runner_5.3.1.bb b/meta-python/recipes-devtools/python/python3-pytest-runner_5.3.1.bb
index 0ca007dd44..fed2d91140 100644
--- a/meta-python/recipes-devtools/python/python3-pytest-runner_5.3.1.bb
+++ b/meta-python/recipes-devtools/python/python3-pytest-runner_5.3.1.bb
@@ -4,8 +4,8 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=7a7126e068206290f3fe9f8d6c713ea6"
SRC_URI[sha256sum] = "0fce5b8dc68760f353979d99fdd6b3ad46330b6b1837e2077a89ebcf204aac91"
-inherit pypi setuptools3
-PIP_INSTALL_PACKAGE = "pytest_runner"
+inherit pypi setuptools_build_meta
+
DEPENDS += " \
${PYTHON_PN}-setuptools-scm-native"
diff --git a/meta-python/recipes-devtools/python/python3-pytest-xdist_2.5.0.bb b/meta-python/recipes-devtools/python/python3-pytest-xdist_2.5.0.bb
index a10ac8cc49..6ad01d08e5 100644
--- a/meta-python/recipes-devtools/python/python3-pytest-xdist_2.5.0.bb
+++ b/meta-python/recipes-devtools/python/python3-pytest-xdist_2.5.0.bb
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=772fcdaca14b378878d05c7d857e6c3e"
SRC_URI[sha256sum] = "4580deca3ff04ddb2ac53eba39d76cb5dd5edeac050cb6fbc768b0dd712b4edf"
-inherit pypi setuptools3
+inherit pypi setuptools_build_meta
DEPENDS += "python3-setuptools-scm-native"
diff --git a/meta-python/recipes-devtools/python/python3-simpleeval_0.9.12.bb b/meta-python/recipes-devtools/python/python3-simpleeval_0.9.12.bb
index 8ad6acc875..279c2562fe 100644
--- a/meta-python/recipes-devtools/python/python3-simpleeval_0.9.12.bb
+++ b/meta-python/recipes-devtools/python/python3-simpleeval_0.9.12.bb
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://LICENCE;md5=dc9277482effe59b734b004cbcc1fee7"
SRC_URI[sha256sum] = "3e0be507486d4e21cf9d08847c7e57dd61a1603950399985f7c5a0be7fd33e36"
-inherit pypi setuptools3 ptest
+inherit pypi setuptools_build_meta ptest
BBCLASSEXTEND = "native nativesdk"
@@ -21,10 +21,6 @@ RDEPENDS:${PN}-ptest += " \
${PYTHON_PN}-pytest \
"
-do_configure:prepend() {
- sed -i -e "/use_2to3=True,/d" ${S}/setup.py
-}
-
do_install_ptest() {
cp -f ${S}/test_simpleeval.py ${D}${PTEST_PATH}/
}
diff --git a/meta-python/recipes-devtools/python/python3-soupsieve_2.3.1.bb b/meta-python/recipes-devtools/python/python3-soupsieve_2.3.1.bb
index f4cf93daba..cb87ec936c 100644
--- a/meta-python/recipes-devtools/python/python3-soupsieve_2.3.1.bb
+++ b/meta-python/recipes-devtools/python/python3-soupsieve_2.3.1.bb
@@ -6,7 +6,7 @@ LIC_FILES_CHKSUM = "file://LICENSE.md;md5=33c3a77def9b3ad83e01c65bdcc1af67"
SRC_URI[sha256sum] = "b8d49b1cd4f037c7082a9683dfa1801aa2597fb11c3a1155b7a5b94829b4f1f9"
-inherit pypi setuptools3 ptest
+inherit pypi setuptools_build_meta ptest
SRC_URI += " \
file://run-ptest \
diff --git a/meta-python/recipes-devtools/python/python3-tqdm_4.63.0.bb b/meta-python/recipes-devtools/python/python3-tqdm_4.63.0.bb
index cd5f1aab53..e7ba1d4e82 100644
--- a/meta-python/recipes-devtools/python/python3-tqdm_4.63.0.bb
+++ b/meta-python/recipes-devtools/python/python3-tqdm_4.63.0.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://LICENCE;md5=1672e2674934fd93a31c09cf17f34100"
SRC_URI[sha256sum] = "1d9835ede8e394bb8c9dcbffbca02d717217113adc679236873eeaac5bc0b3cd"
-inherit pypi setuptools3
+inherit pypi setuptools_build_meta
DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
diff --git a/meta-python/recipes-devtools/python/python3-twine_3.8.0.bb b/meta-python/recipes-devtools/python/python3-twine_3.8.0.bb
index d9aa3dce93..b96e153b5a 100644
--- a/meta-python/recipes-devtools/python/python3-twine_3.8.0.bb
+++ b/meta-python/recipes-devtools/python/python3-twine_3.8.0.bb
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=a3d1106b253a8d50dd82a4202a045b4c"
SRC_URI[sha256sum] = "8efa52658e0ae770686a13b675569328f1fba9837e5de1867bfe5f46a9aefe19"
-inherit pypi setuptools3
+inherit pypi setuptools_build_meta
DEPENDS += "\
${PYTHON_PN}-setuptools-scm-native \
@@ -15,9 +15,4 @@ RDEPENDS:${PN} += " \
${PYTHON_PN}-importlib-metadata \
"
-do_compile:prepend() {
- echo "from setuptools import setup" > ${S}/setup.py
- echo "setup()" >> ${S}/setup.py
-}
-
BBCLASSEXTEND = "native"
diff --git a/meta-python/recipes-devtools/python/python3-waitress_2.1.0.bb b/meta-python/recipes-devtools/python/python3-waitress_2.1.0.bb
index 99e483962f..31a77c5b9e 100644
--- a/meta-python/recipes-devtools/python/python3-waitress_2.1.0.bb
+++ b/meta-python/recipes-devtools/python/python3-waitress_2.1.0.bb
@@ -8,4 +8,4 @@ LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=78ccb3640dc841e1baecb3e27a6966b2"
SRC_URI[sha256sum] = "ec8a8d9b6b15f3bb2c1a82b8f3929a029c333c35fcafb08c185a9e562d8cc9c2"
-inherit setuptools3 pypi
+inherit setuptools_build_meta pypi