aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJustin Bronder <jsbronder@cold-front.org>2022-03-07 16:59:00 -0500
committerKhem Raj <raj.khem@gmail.com>2022-03-08 08:06:33 -0800
commit81693af8b430c0065f0c21e387278b946b328ca6 (patch)
tree4c07c63b64016f4b6100473d7a0247fe684a06d0
parent81b5151c8d658300f9e6c031071d50e7f22dcd8a (diff)
downloadmeta-openembedded-contrib-81693af8b430c0065f0c21e387278b946b328ca6.tar.gz
python3-asyncinotify: add 2.0.2
Signed-off-by: Justin Bronder <jsbronder@cold-front.org> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-asyncinotify_2.0.2.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-asyncinotify_2.0.2.bb b/meta-python/recipes-devtools/python/python3-asyncinotify_2.0.2.bb
new file mode 100644
index 0000000000..2bf9192481
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-asyncinotify_2.0.2.bb
@@ -0,0 +1,15 @@
+SUMMARY = "A simple optionally-async python inotify library, focused on simplicity of use and operation, and leveraging modern Python features"
+HOMEPAGE = "https://gitlab.com/Taywee/asyncinotify"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=6ec941a1cd6616454970d03cb9c9e8f8"
+
+SRC_URI[sha256sum] = "867cc056d88fc07aa8b3d1dc5b9c3c911cdd6130a4df5f67beb1fdecfd37b164"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += " \
+ python3-asyncio \
+ python3-core \
+ python3-ctypes \
+ python3-io \
+"