aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorzhengruoqin <zhengrq.fnst@fujitsu.com>2022-07-07 15:55:05 +0800
committerKhem Raj <raj.khem@gmail.com>2022-07-07 08:24:26 -0700
commit79c71335803d8859eb419c208aa3f66722d54fc4 (patch)
tree0b550bbeb8af780704d209eef17fd31866809a20
parent5a2554bd5e4b1ce3a3e21498fd5d5acfac14ed62 (diff)
downloadmeta-openembedded-contrib-79c71335803d8859eb419c208aa3f66722d54fc4.tar.gz
python3-grpcio-tools: upgrade 1.46.3 -> 1.47.0
0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch refreshed for new version. Signed-off-by: Zheng Ruoqin <zhengrq.fnst@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-grpcio-tools/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch13
-rw-r--r--meta-python/recipes-devtools/python/python3-grpcio-tools_1.47.0.bb (renamed from meta-python/recipes-devtools/python/python3-grpcio-tools_1.46.3.bb)2
2 files changed, 10 insertions, 5 deletions
diff --git a/meta-python/recipes-devtools/python/python3-grpcio-tools/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch b/meta-python/recipes-devtools/python/python3-grpcio-tools/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch
index 4713da174f..4aa11bd57a 100644
--- a/meta-python/recipes-devtools/python/python3-grpcio-tools/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch
+++ b/meta-python/recipes-devtools/python/python3-grpcio-tools/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch
@@ -26,6 +26,8 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
setup.py | 9 ++++++---
1 file changed, 6 insertions(+), 3 deletions(-)
+diff --git a/setup.py b/setup.py
+index cc53e79..be3bc78 100644
--- a/setup.py
+++ b/setup.py
@@ -87,8 +87,11 @@ def check_linker_need_libatomic():
@@ -33,12 +35,12 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
code_test = (b'#include <atomic>\n' +
b'int main() { return std::atomic<int64_t>{}; }')
- cxx = os.environ.get('CXX', 'c++')
-- cpp_test = subprocess.Popen([cxx, '-x', 'c++', '-std=c++11', '-'],
+- cpp_test = subprocess.Popen([cxx, '-x', 'c++', '-std=c++14', '-'],
+ cxx, cxx_args = os.environ.get('CXX').split(' ', 1) or 'c++'
+ if not cxx_args:
+ cxx_args = "-g"
+
-+ cpp_test = subprocess.Popen([cxx, cxx_args, '-x', 'c++', '-std=c++11', '-'],
++ cpp_test = subprocess.Popen([cxx, cxx_args, '-x', 'c++', '-std=c++14', '-'],
stdin=PIPE,
stdout=PIPE,
stderr=PIPE)
@@ -46,8 +48,11 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
# Double-check to see if -latomic actually can solve the problem.
# https://github.com/grpc/grpc/issues/22491
cpp_test = subprocess.Popen(
-- [cxx, '-x', 'c++', '-std=c++11', '-', '-latomic'],
-+ [cxx, cxx_args, '-x', 'c++', '-std=c++11', '-', '-latomic'],
+- [cxx, '-x', 'c++', '-std=c++14', '-', '-latomic'],
++ [cxx, cxx_args, '-x', 'c++', '-std=c++14', '-', '-latomic'],
stdin=PIPE,
stdout=PIPE,
stderr=PIPE)
+--
+2.25.1
+
diff --git a/meta-python/recipes-devtools/python/python3-grpcio-tools_1.46.3.bb b/meta-python/recipes-devtools/python/python3-grpcio-tools_1.47.0.bb
index 221a05ef1a..90c8efeeca 100644
--- a/meta-python/recipes-devtools/python/python3-grpcio-tools_1.46.3.bb
+++ b/meta-python/recipes-devtools/python/python3-grpcio-tools_1.47.0.bb
@@ -10,7 +10,7 @@ inherit pypi setuptools3
DEPENDS += "${PYTHON_PN}-grpcio"
SRC_URI += "file://0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch"
-SRC_URI[sha256sum] = "31fee436ace5b3bd950cc3a8e68d6b84de1d6dc755959db7badc3470cdf22f70"
+SRC_URI[sha256sum] = "f64b5378484be1d6ce59311f86174be29c8ff98d8d90f589e1c56d5acae67d3c"
RDEPENDS:${PN} = "${PYTHON_PN}-grpcio"