aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Stewart <alex.stewart@ni.com>2022-07-08 10:58:33 -0500
committerKhem Raj <raj.khem@gmail.com>2022-07-08 22:43:03 -0400
commit59be04fbcd07c0862a2b74add48e30200db4395c (patch)
tree6ba5219dbb73911f0b700c7f9f51b7b2ebcec396
parent40a55b3215e5d93e6ea83433ac236647a2f93529 (diff)
downloadmeta-openembedded-contrib-59be04fbcd07c0862a2b74add48e30200db4395c.tar.gz
openvpn: distribute sample-config-files
The openvpn tarball has additional sample config files which are generally useful to users, and which are typically distributed in other distros' openvpn packages. Include these sample configs in the OE recipe. Signed-off-by: Bill Pittman <bill.pittman@ni.com> Rebased to openvpn_2.5.7. Signed-off-by: Alex Stewart <alex.stewart@ni.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-networking/recipes-support/openvpn/openvpn_2.5.7.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/openvpn/openvpn_2.5.7.bb b/meta-networking/recipes-support/openvpn/openvpn_2.5.7.bb
index 1395a35f54..a28c73ab5a 100644
--- a/meta-networking/recipes-support/openvpn/openvpn_2.5.7.bb
+++ b/meta-networking/recipes-support/openvpn/openvpn_2.5.7.bb
@@ -54,8 +54,12 @@ do_install:append() {
install -d ${D}/${sysconfdir}/openvpn/sample
install -m 644 ${S}/sample/sample-config-files/loopback-server ${D}${sysconfdir}/openvpn/sample/loopback-server.conf
install -m 644 ${S}/sample/sample-config-files/loopback-client ${D}${sysconfdir}/openvpn/sample/loopback-client.conf
+ install -dm 755 ${D}${sysconfdir}/openvpn/sample/sample-config-files
install -dm 755 ${D}${sysconfdir}/openvpn/sample/sample-keys
+ install -dm 755 ${D}${sysconfdir}/openvpn/sample/sample-scripts
+ install -m 644 ${S}/sample/sample-config-files/* ${D}${sysconfdir}/openvpn/sample/sample-config-files
install -m 644 ${S}/sample/sample-keys/* ${D}${sysconfdir}/openvpn/sample/sample-keys
+ install -m 644 ${S}/sample/sample-scripts/* ${D}${sysconfdir}/openvpn/sample/sample-scripts
install -d -m 710 ${D}/${localstatedir}/lib/openvpn
}