aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@arm.com>2022-05-23 14:02:55 +0100
committerRoss Burton <ross.burton@arm.com>2022-07-14 13:40:25 +0100
commit097f27386a2afb41262f365f86cccced5e0547d7 (patch)
treeb335b9e31e650cb566b32de1567c60992c9398be
parent4954118b5e69b7ccbd249d2cdb3661ca26affc3d (diff)
downloadmeta-openembedded-contrib-097f27386a2afb41262f365f86cccced5e0547d7.tar.gz
python3-simpleeval: remove 'build' build dependency
In the future we'll have a Python building tool which validates build requirements. No package should require a specific tool to be present (not even used, just present), so remove the dependency on 'build'. Signed-off-by: Ross Burton <ross.burton@arm.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-simpleeval/no-build.patch24
-rw-r--r--meta-python/recipes-devtools/python/python3-simpleeval_0.9.12.bb1
2 files changed, 25 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-simpleeval/no-build.patch b/meta-python/recipes-devtools/python/python3-simpleeval/no-build.patch
new file mode 100644
index 0000000000..b090755f8a
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-simpleeval/no-build.patch
@@ -0,0 +1,24 @@
+Upstream-Status: Submitted [https://github.com/danthedeckie/simpleeval/pull/119]
+Signed-off-by: Ross Burton <ross.burton@arm.com>
+
+From 08bc99211aec32882d5f1c83896eb5d72b9fb125 Mon Sep 17 00:00:00 2001
+From: Ross Burton <ross.burton@arm.com>
+Date: Mon, 23 May 2022 11:35:00 +0100
+Subject: [PATCH] pyproject.toml: remove build as a build-dependency
+
+pypa/build is one possible build tool, but not the only build tool. Forcing build to be present as a build dependency is meaningless: either the user is using build so obviously have build, or are using something else so having build is irrelevant.
+---
+ pyproject.toml | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/pyproject.toml b/pyproject.toml
+index 052a55a..416482b 100644
+--- a/pyproject.toml
++++ b/pyproject.toml
+@@ -1,5 +1,5 @@
+ [build-system]
+-requires = ["setuptools>=30.3.0", "wheel", "build"]
++requires = ["setuptools>=30.3.0", "wheel"]
+ build-backend = "setuptools.build_meta"
+
+ [tool.black]
diff --git a/meta-python/recipes-devtools/python/python3-simpleeval_0.9.12.bb b/meta-python/recipes-devtools/python/python3-simpleeval_0.9.12.bb
index 343e5c03de..c9cf33d023 100644
--- a/meta-python/recipes-devtools/python/python3-simpleeval_0.9.12.bb
+++ b/meta-python/recipes-devtools/python/python3-simpleeval_0.9.12.bb
@@ -10,6 +10,7 @@ inherit pypi python_setuptools_build_meta ptest
BBCLASSEXTEND = "native nativesdk"
SRC_URI += " \
+ file://no-build.patch \
file://run-ptest \
"