aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Bunk <bunk@stusta.de>2019-07-02 19:35:31 +0300
committerKhem Raj <raj.khem@gmail.com>2019-07-10 09:24:33 -0700
commit3a4dfcce5de01f001ba29db5879752ec8e5acf87 (patch)
tree434d4c1a3ff612161b3b8b08cbc6bd63ddee5937
parent4e6eb595c048695ba95ac680f954fa30b888a5b0 (diff)
downloadmeta-openembedded-contrib-3a4dfcce5de01f001ba29db5879752ec8e5acf87.tar.gz
cpprest: Fix build failure with gcc 8
The workaround for gcc 9 broke building with gcc 8: cc1plus: error: -Werror=deprecated-copy: no option -Wdeprecated-copy cc1plus: error: -Werror=redundant-move: no option -Wredundant-move ninja: build stopped: subcommand failed. -Werror is often problematic in distribution builds, disable it globally and permanently. Signed-off-by: Adrian Bunk <bunk@stusta.de> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-support/cpprest/cpprest_2.10.13.bb4
1 files changed, 1 insertions, 3 deletions
diff --git a/meta-oe/recipes-support/cpprest/cpprest_2.10.13.bb b/meta-oe/recipes-support/cpprest/cpprest_2.10.13.bb
index 0704512110..3e42a002ef 100644
--- a/meta-oe/recipes-support/cpprest/cpprest_2.10.13.bb
+++ b/meta-oe/recipes-support/cpprest/cpprest_2.10.13.bb
@@ -18,6 +18,4 @@ S = "${WORKDIR}/git"
inherit cmake pkgconfig
-# Temporary until https://github.com/Microsoft/cpprestsdk/issues/1099
-# is fixed properly
-CXXFLAGS += "-Wno-error=deprecated-copy -Wno-error=redundant-move"
+CXXFLAGS += "-Wno-error"