aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2018-01-21 11:20:31 -0500
committerArmin Kuster <akuster808@gmail.com>2018-01-26 17:28:11 -0800
commit90b1f996af78504a6ea233d6db976a9752981511 (patch)
treef4ba22268a838db8038e8592c4d243b5c9a8d20a
parent6c2571e713f77f59c9ce255a5699f7836d8bb3bc (diff)
downloadmeta-openembedded-contrib-90b1f996af78504a6ea233d6db976a9752981511.tar.gz
Remove deprecated python3-argparse from the RDEPENDS
The python3-argparse package was removed as part of the migration to the json manifest file. The functionality is now part of core Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-support/canonical-multitouch/geis_2.2.17.bb1
-rw-r--r--meta-python/recipes-devtools/python/python-can.inc1
-rw-r--r--meta-python/recipes-devtools/python/python-can_2.0.0.bb1
-rw-r--r--meta-python/recipes-devtools/python/python-chardet.inc1
-rw-r--r--meta-python/recipes-devtools/python/python-chardet_3.0.4.bb2
-rw-r--r--meta-python/recipes-devtools/python/python-django.inc1
-rw-r--r--meta-python/recipes-devtools/python/python-django_1.11.9.bb2
-rw-r--r--meta-python/recipes-devtools/python/python-pyserial.inc1
-rw-r--r--meta-python/recipes-devtools/python/python-pyserial_3.4.bb2
-rw-r--r--meta-python/recipes-devtools/python/python-pytest-runner.inc2
-rw-r--r--meta-python/recipes-devtools/python/python-pytest-runner_3.0.bb2
-rw-r--r--meta-python/recipes-devtools/python/python-pytest.inc1
-rw-r--r--meta-python/recipes-devtools/python/python-pytest_3.3.2.bb1
-rw-r--r--meta-python/recipes-devtools/python/python-setuptools-scm.inc2
-rw-r--r--meta-python/recipes-devtools/python/python-setuptools-scm_1.15.7.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-langtable_0.0.38.bb1
16 files changed, 11 insertions, 12 deletions
diff --git a/meta-oe/recipes-support/canonical-multitouch/geis_2.2.17.bb b/meta-oe/recipes-support/canonical-multitouch/geis_2.2.17.bb
index 976aafb4fc..ff08361b56 100644
--- a/meta-oe/recipes-support/canonical-multitouch/geis_2.2.17.bb
+++ b/meta-oe/recipes-support/canonical-multitouch/geis_2.2.17.bb
@@ -30,7 +30,6 @@ EXTRA_OECONF = "--disable-integration-tests"
FILES_${PN}-bin = "${bindir}"
RDEPENDS_${PN}-bin = " \
- python3-argparse \
python3-compression \
python3-core \
python3-crypt \
diff --git a/meta-python/recipes-devtools/python/python-can.inc b/meta-python/recipes-devtools/python/python-can.inc
index 802098ad32..8cdd4d38fd 100644
--- a/meta-python/recipes-devtools/python/python-can.inc
+++ b/meta-python/recipes-devtools/python/python-can.inc
@@ -9,7 +9,6 @@ SRC_URI[sha256sum] = "da89e94fa234d4ebe7f43a26d4b06a5d14ea767fbd2c4767732e4d9644
PYPI_PACKAGE="python-can"
RDEPENDS_${PN}_class-target += "\
- ${PYTHON_PN}-argparse \
${PYTHON_PN}-ctypes \
${PYTHON_PN}-importlib \
${PYTHON_PN}-logging \
diff --git a/meta-python/recipes-devtools/python/python-can_2.0.0.bb b/meta-python/recipes-devtools/python/python-can_2.0.0.bb
index a698ad3651..fcfde2f638 100644
--- a/meta-python/recipes-devtools/python/python-can_2.0.0.bb
+++ b/meta-python/recipes-devtools/python/python-can_2.0.0.bb
@@ -2,5 +2,6 @@ require python-can.inc
inherit pypi setuptools
RDEPENDS_${PN}_class-target += "\
+ ${PYTHON_PN}-argparse \
${PYTHON_PN}-zlib \
"
diff --git a/meta-python/recipes-devtools/python/python-chardet.inc b/meta-python/recipes-devtools/python/python-chardet.inc
index 246a65aa60..6305299780 100644
--- a/meta-python/recipes-devtools/python/python-chardet.inc
+++ b/meta-python/recipes-devtools/python/python-chardet.inc
@@ -19,6 +19,5 @@ FILES_${PN}-cli += " \
"
RDEPENDS_${PN}_class-target += " \
- ${PYTHON_PN}-argparse \
${PYTHON_PN}-logging \
"
diff --git a/meta-python/recipes-devtools/python/python-chardet_3.0.4.bb b/meta-python/recipes-devtools/python/python-chardet_3.0.4.bb
index b7a46e9d7b..3b6feeef11 100644
--- a/meta-python/recipes-devtools/python/python-chardet_3.0.4.bb
+++ b/meta-python/recipes-devtools/python/python-chardet_3.0.4.bb
@@ -1,2 +1,4 @@
inherit setuptools
require python-chardet.inc
+
+RDEPENDS_${PN} += "${PYTHON_PN}-argparse"
diff --git a/meta-python/recipes-devtools/python/python-django.inc b/meta-python/recipes-devtools/python/python-django.inc
index 8fff75d5ac..9287715eab 100644
--- a/meta-python/recipes-devtools/python/python-django.inc
+++ b/meta-python/recipes-devtools/python/python-django.inc
@@ -14,7 +14,6 @@ FILES_${PN} += "${datadir}/django"
BBCLASSEXTEND = "native nativesdk"
RDEPENDS_${PN} += "\
- ${PYTHON_PN}-argparse \
${PYTHON_PN}-compression \
${PYTHON_PN}-ctypes \
${PYTHON_PN}-datetime \
diff --git a/meta-python/recipes-devtools/python/python-django_1.11.9.bb b/meta-python/recipes-devtools/python/python-django_1.11.9.bb
index ed92c9bfe0..db48ffdd79 100644
--- a/meta-python/recipes-devtools/python/python-django_1.11.9.bb
+++ b/meta-python/recipes-devtools/python/python-django_1.11.9.bb
@@ -1,4 +1,4 @@
require python-django.inc
inherit setuptools
-RDEPENDS_${PN} += "${PYTHON_PN}-zlib"
+RDEPENDS_${PN} += "${PYTHON_PN}-argparse ${PYTHON_PN}-zlib"
diff --git a/meta-python/recipes-devtools/python/python-pyserial.inc b/meta-python/recipes-devtools/python/python-pyserial.inc
index 8fe3f2c5ec..52a7e05ce6 100644
--- a/meta-python/recipes-devtools/python/python-pyserial.inc
+++ b/meta-python/recipes-devtools/python/python-pyserial.inc
@@ -31,7 +31,6 @@ FILES_${PN}-win32 = " \
"
RDEPENDS_${PN} = "\
- ${PYTHON_PN}-argparse \
${PYTHON_PN}-fcntl \
${PYTHON_PN}-io \
${PYTHON_PN}-logging \
diff --git a/meta-python/recipes-devtools/python/python-pyserial_3.4.bb b/meta-python/recipes-devtools/python/python-pyserial_3.4.bb
index 91a0f26ac3..0497087ac3 100644
--- a/meta-python/recipes-devtools/python/python-pyserial_3.4.bb
+++ b/meta-python/recipes-devtools/python/python-pyserial_3.4.bb
@@ -1,4 +1,4 @@
inherit setuptools
require python-pyserial.inc
-RDEPENDS_${PN} += "${PYTHON_PN}-importlib"
+RDEPENDS_${PN} += "${PYTHON_PN}-argparse ${PYTHON_PN}-importlib"
diff --git a/meta-python/recipes-devtools/python/python-pytest-runner.inc b/meta-python/recipes-devtools/python/python-pytest-runner.inc
index 262448de1b..7546743fb4 100644
--- a/meta-python/recipes-devtools/python/python-pytest-runner.inc
+++ b/meta-python/recipes-devtools/python/python-pytest-runner.inc
@@ -10,7 +10,7 @@ inherit pypi
DEPENDS += " \
${PYTHON_PN}-setuptools-scm-native"
-RDEPENDS_${PN} = "${PYTHON_PN}-py ${PYTHON_PN}-setuptools ${PYTHON_PN}-argparse ${PYTHON_PN}-debugger ${PYTHON_PN}-json \
+RDEPENDS_${PN} = "${PYTHON_PN}-py ${PYTHON_PN}-setuptools ${PYTHON_PN}-debugger ${PYTHON_PN}-json \
${PYTHON_PN}-io"
BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python-pytest-runner_3.0.bb b/meta-python/recipes-devtools/python/python-pytest-runner_3.0.bb
index 0a5055cb37..1765a732d0 100644
--- a/meta-python/recipes-devtools/python/python-pytest-runner_3.0.bb
+++ b/meta-python/recipes-devtools/python/python-pytest-runner_3.0.bb
@@ -2,4 +2,4 @@ inherit setuptools
require python-pytest-runner.inc
# Dependency only exists for python2
-RDEPENDS_${PN} += "python-compiler"
+RDEPENDS_${PN} += "python-argparse python-compiler"
diff --git a/meta-python/recipes-devtools/python/python-pytest.inc b/meta-python/recipes-devtools/python/python-pytest.inc
index 17d8233f82..c997da9901 100644
--- a/meta-python/recipes-devtools/python/python-pytest.inc
+++ b/meta-python/recipes-devtools/python/python-pytest.inc
@@ -10,7 +10,6 @@ SRC_URI_append = " file://0001-setup.py-remove-the-setup_requires-for-setuptools
file://pytest_version_fix.patch "
RDEPENDS_${PN}_class-target += " \
- ${PYTHON_PN}-argparse \
${PYTHON_PN}-attrs \
${PYTHON_PN}-debugger \
${PYTHON_PN}-json \
diff --git a/meta-python/recipes-devtools/python/python-pytest_3.3.2.bb b/meta-python/recipes-devtools/python/python-pytest_3.3.2.bb
index d7bd0a4028..201ab050cd 100644
--- a/meta-python/recipes-devtools/python/python-pytest_3.3.2.bb
+++ b/meta-python/recipes-devtools/python/python-pytest_3.3.2.bb
@@ -2,6 +2,7 @@ inherit pypi setuptools
require python-pytest.inc
RDEPENDS_${PN}_class-target += " \
+ ${PYTHON_PN}-argparse \
${PYTHON_PN}-compiler \
${PYTHON_PN}-funcsigs \
"
diff --git a/meta-python/recipes-devtools/python/python-setuptools-scm.inc b/meta-python/recipes-devtools/python/python-setuptools-scm.inc
index 7a58f14e4f..eb66580a6e 100644
--- a/meta-python/recipes-devtools/python/python-setuptools-scm.inc
+++ b/meta-python/recipes-devtools/python/python-setuptools-scm.inc
@@ -8,7 +8,7 @@ SRC_URI[sha256sum] = "e163e8a12d2121f77575773cfc2b5988275dc1f1d2541fdf780127c29d
PYPI_PACKAGE = "setuptools_scm"
inherit pypi
-RDEPENDS_${PN}_class-target = "${PYTHON_PN}-py ${PYTHON_PN}-setuptools ${PYTHON_PN}-argparse ${PYTHON_PN}-debugger ${PYTHON_PN}-json"
+RDEPENDS_${PN}_class-target = "${PYTHON_PN}-py ${PYTHON_PN}-setuptools ${PYTHON_PN}-debugger ${PYTHON_PN}-json"
RDEPENDS_${PN}_class-native = "${PYTHON_PN}-setuptools-native"
BBCLASSEXTEND = "native"
diff --git a/meta-python/recipes-devtools/python/python-setuptools-scm_1.15.7.bb b/meta-python/recipes-devtools/python/python-setuptools-scm_1.15.7.bb
index 5f9bb0b5c0..64b36e3a01 100644
--- a/meta-python/recipes-devtools/python/python-setuptools-scm_1.15.7.bb
+++ b/meta-python/recipes-devtools/python/python-setuptools-scm_1.15.7.bb
@@ -1,2 +1,4 @@
inherit setuptools
require python-setuptools-scm.inc
+
+RDEPENDS_${PN} += "${PYTHON_PN}-argparse"
diff --git a/meta-python/recipes-devtools/python/python3-langtable_0.0.38.bb b/meta-python/recipes-devtools/python/python3-langtable_0.0.38.bb
index 436a664a86..0ca58c7b73 100644
--- a/meta-python/recipes-devtools/python/python3-langtable_0.0.38.bb
+++ b/meta-python/recipes-devtools/python/python3-langtable_0.0.38.bb
@@ -22,7 +22,6 @@ DISTUTILS_INSTALL_ARGS = "--prefix=${D}/${prefix} \
FILES_${PN} += "${datadir}/*"
RDEPENDS_${PN} += " \
- ${PYTHON_PN}-argparse \
${PYTHON_PN}-compression \
${PYTHON_PN}-doctest \
${PYTHON_PN}-logging \