aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Kolbus <peter.kolbus@garmin.com>2020-01-02 12:37:43 -0600
committerKhem Raj <raj.khem@gmail.com>2020-01-02 19:29:25 -0800
commit5b15fb9c839a276220651946efd1d1a303ff0d45 (patch)
treec4af2918b7ce9b63a89d56dedfe376532470f0fb
parent8cb441b64045bb2edddf46b5d6b0c0713cbc55a0 (diff)
downloadmeta-openembedded-contrib-5b15fb9c839a276220651946efd1d1a303ff0d45.tar.gz
python3-license-expression: add recipe
python3-license-expression is a utility library to parse and work with license expressions. Signed-off-by: Peter Kolbus <peter.kolbus@garmin.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python-license-expression.inc16
-rw-r--r--meta-python/recipes-devtools/python/python3-license-expression_1.0.bb2
2 files changed, 18 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-license-expression.inc b/meta-python/recipes-devtools/python/python-license-expression.inc
new file mode 100644
index 0000000000..4c35e8dd70
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-license-expression.inc
@@ -0,0 +1,16 @@
+SUMMARY = "Utility library to parse, compare, simplify and normalize license expressions"
+HOMEPAGE = "https://github.com/nexB/license-expression"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://apache-2.0.LICENSE;md5=e23fadd6ceef8c618fc1c65191d846fa"
+
+SRC_URI[md5sum] = "81477f779099f55071c6a7b88a29bb01"
+SRC_URI[sha256sum] = "8aaa455c5b97c4f2174090178b19792b2a1c620e80591aafd4e0a99b713f9e8d"
+
+inherit pypi
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-booleanpy \
+ "
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python3-license-expression_1.0.bb b/meta-python/recipes-devtools/python/python3-license-expression_1.0.bb
new file mode 100644
index 0000000000..10a702ca45
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-license-expression_1.0.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-license-expression.inc