aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2021-12-03 11:21:04 +0800
committerKhem Raj <raj.khem@gmail.com>2021-12-02 22:40:22 -0800
commitbde2553860b4c3cfab70bd493abd1c40afe73668 (patch)
treeeadd10319aa31c7768f3c1229efcee5d76651bee
parent73acbc295261d6648d7ead0c53610e4cdc4deb37 (diff)
downloadmeta-openembedded-contrib-bde2553860b4c3cfab70bd493abd1c40afe73668.tar.gz
ostree: workaround compile error with option gcc option -Og
While DEBUG_BUILD = "1" in local.conf, `-Og' is added to cfalgs by Yocto, it broke ostree build with `-Werror=aggregate-return' (the -Werror=aggregate-return is added by ostree configure.ac) So remove -Og and use -O2 as workaround Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-extended/ostree/ostree_2021.6.bb8
1 files changed, 8 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/ostree/ostree_2021.6.bb b/meta-oe/recipes-extended/ostree/ostree_2021.6.bb
index 9e0f7bc7c4..d2d5dc0aa0 100644
--- a/meta-oe/recipes-extended/ostree/ostree_2021.6.bb
+++ b/meta-oe/recipes-extended/ostree/ostree_2021.6.bb
@@ -29,6 +29,14 @@ S = "${WORKDIR}/git"
inherit autotools bash-completion gobject-introspection gtk-doc manpages pkgconfig ptest-gnome systemd
+# Workaround compile failure:
+# |../git/src/libotutil/zbase32.c:37:1: error: function returns an aggregate [-Werror=aggregate-return]
+# so remove -Og and use -O2 as workaround
+DEBUG_OPTIMIZATION:remove = "-Og"
+DEBUG_OPTIMIZATION:append = " -O2"
+BUILD_OPTIMIZATION:remove = "-Og"
+BUILD_OPTIMIZATION:append = " -O2"
+
# Package configuration - match ostree defaults, but without rofiles-fuse
# otherwise we introduce a dependendency on meta-filesystems
PACKAGECONFIG ??= " \