aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTrevor Gamblin <trevor.gamblin@windriver.com>2021-12-01 15:41:17 -0500
committerKhem Raj <raj.khem@gmail.com>2021-12-01 12:47:27 -0800
commita7313d45035ea3340c520a98436de7fa4c8cd49a (patch)
treea5404399429dd5ba2caec65861fa213bae446413
parent260968790546acce067ab1265f53ceb40791dfa1 (diff)
downloadmeta-openembedded-contrib-a7313d45035ea3340c520a98436de7fa4c8cd49a.tar.gz
libnftnl: upgrade 1.2.0 -> 1.2.1
Also fix patch contributor name in the process of reworking it to apply on the new 1.2.1 release (I had accidentally modified it when reworking it previously). Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-networking/recipes-filter/libnftnl/libnftnl/0001-avoid-naming-local-function-as-one-of-printf-family.patch29
-rw-r--r--meta-networking/recipes-filter/libnftnl/libnftnl_1.2.1.bb (renamed from meta-networking/recipes-filter/libnftnl/libnftnl_1.2.0.bb)2
2 files changed, 23 insertions, 8 deletions
diff --git a/meta-networking/recipes-filter/libnftnl/libnftnl/0001-avoid-naming-local-function-as-one-of-printf-family.patch b/meta-networking/recipes-filter/libnftnl/libnftnl/0001-avoid-naming-local-function-as-one-of-printf-family.patch
index 62328203dd..68eb04a83e 100644
--- a/meta-networking/recipes-filter/libnftnl/libnftnl/0001-avoid-naming-local-function-as-one-of-printf-family.patch
+++ b/meta-networking/recipes-filter/libnftnl/libnftnl/0001-avoid-naming-local-function-as-one-of-printf-family.patch
@@ -1,6 +1,6 @@
-From c29959e045dd09d0b5727682d4e9dbc10923ac4f Mon Sep 17 00:00:00 2001
-From: Trevor Gamblin <trevor.gamblin@windriver.com>
-Date: Wed, 2 Jun 2021 11:08:51 -0400
+From e03b003610a176d608da9a02e433e7ded7e4b75f Mon Sep 17 00:00:00 2001
+From: Todd Cunningham <tcunningham07@gmail.com>
+Date: Wed, 11 Dec 2019 10:18:56 +1000
Subject: [PATCH] avoid naming local function as one of printf family
Fixes build issues with clang
@@ -14,6 +14,9 @@ Signed-off-by: Todd Cunningham <tcunningham07@gmail.com>
Use wiggle to get the patch to apply for version 1.2.0.
+Add the same change in src/expr/last.c to make the patch apply for
+1.2.1. Also correct the patch to show the original author and metadata.
+
Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
---
include/expr_ops.h | 2 +-
@@ -33,6 +36,7 @@ Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
src/expr/fwd.c | 2 +-
src/expr/hash.c | 2 +-
src/expr/immediate.c | 2 +-
+ src/expr/last.c | 2 +-
src/expr/limit.c | 2 +-
src/expr/log.c | 2 +-
src/expr/lookup.c | 2 +-
@@ -66,7 +70,7 @@ Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
src/obj/synproxy.c | 2 +-
src/obj/tunnel.c | 2 +-
src/object.c | 2 +-
- 50 files changed, 51 insertions(+), 51 deletions(-)
+ 51 files changed, 52 insertions(+), 52 deletions(-)
diff --git a/include/expr_ops.h b/include/expr_ops.h
index 7a6aa23..d3a2855 100644
@@ -265,6 +269,17 @@ index 94b043c..a8a3c1f 100644
- .snprintf = nftnl_expr_immediate_snprintf,
+ .snprintf_ = nftnl_expr_immediate_snprintf,
};
+diff --git a/src/expr/last.c b/src/expr/last.c
+index e2a60c4..2f75464 100644
+--- a/src/expr/last.c
++++ b/src/expr/last.c
+@@ -134,5 +134,5 @@ struct expr_ops expr_ops_last = {
+ .get = nftnl_expr_last_get,
+ .parse = nftnl_expr_last_parse,
+ .build = nftnl_expr_last_build,
+- .snprintf = nftnl_expr_last_snprintf,
++ .snprintf_ = nftnl_expr_last_snprintf,
+ };
diff --git a/src/expr/limit.c b/src/expr/limit.c
index 3dfd54a..f652df0 100644
--- a/src/expr/limit.c
@@ -376,10 +391,10 @@ index 215a681..75a6b3c 100644
+ .snprintf_ = nftnl_expr_osf_snprintf,
};
diff --git a/src/expr/payload.c b/src/expr/payload.c
-index 9ccb78e..aa17025 100644
+index 82747ec..e9130ec 100644
--- a/src/expr/payload.c
+++ b/src/expr/payload.c
-@@ -258,5 +258,5 @@ struct expr_ops expr_ops_payload = {
+@@ -259,5 +259,5 @@ struct expr_ops expr_ops_payload = {
.get = nftnl_expr_payload_get,
.parse = nftnl_expr_payload_parse,
.build = nftnl_expr_payload_build,
@@ -631,5 +646,5 @@ index 46e208b..d321c50 100644
}
ret = snprintf(buf + offset, remain, "]");
--
-2.31.1
+2.33.1
diff --git a/meta-networking/recipes-filter/libnftnl/libnftnl_1.2.0.bb b/meta-networking/recipes-filter/libnftnl/libnftnl_1.2.1.bb
index d4aa267fa7..16de8589a7 100644
--- a/meta-networking/recipes-filter/libnftnl/libnftnl_1.2.0.bb
+++ b/meta-networking/recipes-filter/libnftnl/libnftnl_1.2.1.bb
@@ -4,7 +4,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=79808397c3355f163c012616125c9e26"
SECTION = "libs"
DEPENDS = "libmnl"
-SRCREV = "d45be40eef72f0d42a1ba82efddbb0970d4c760a"
+SRCREV = "09456c720e9c00eecc08e41ac6b7c291b3821ee5"
SRC_URI = "git://git.netfilter.org/libnftnl;branch=master \
file://0001-avoid-naming-local-function-as-one-of-printf-family.patch \
"