aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2021-12-02 10:22:38 +0800
committerKhem Raj <raj.khem@gmail.com>2021-12-01 20:36:31 -0800
commit1bacbe783ad81ec23ae4a6954b811a53a4af433d (patch)
treed223d853b08a60a071539e3ef2c282d2eb8bd3ae
parenta7313d45035ea3340c520a98436de7fa4c8cd49a (diff)
downloadmeta-openembedded-contrib-1bacbe783ad81ec23ae4a6954b811a53a4af433d.tar.gz
ostree: add nativesdk support
# Changed in V2: s/$OECORE_NATIVE_SYSROOT/\$OECORE_NATIVE_SYSROOT/ for # ostree wrapper of nativesdk Refer the impment of native, use the same PACKAGECONFIG, EXTRA_OECONF and similar create_wrapper for ostree Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-extended/ostree/ostree_2021.6.bb18
1 files changed, 17 insertions, 1 deletions
diff --git a/meta-oe/recipes-extended/ostree/ostree_2021.6.bb b/meta-oe/recipes-extended/ostree/ostree_2021.6.bb
index 8f37a7f86f..a802076890 100644
--- a/meta-oe/recipes-extended/ostree/ostree_2021.6.bb
+++ b/meta-oe/recipes-extended/ostree/ostree_2021.6.bb
@@ -52,6 +52,13 @@ PACKAGECONFIG:class-native ??= " \
soup \
"
+PACKAGECONFIG:class-nativesdk ??= " \
+ ${@bb.utils.filter('DISTRO_FEATURES', 'selinux smack', d)} \
+ builtin-grub2-mkconfig \
+ gpgme \
+ soup \
+"
+
PACKAGECONFIG[avahi] = "--with-avahi, --without-avahi, avahi"
PACKAGECONFIG[builtin-grub2-mkconfig] = "--with-builtin-grub2-mkconfig, --without-builtin-grub2-mkconfig"
PACKAGECONFIG[curl] = "--with-curl, --without-curl, curl"
@@ -89,6 +96,11 @@ EXTRA_OECONF:class-native = " \
--disable-otmpfile \
"
+EXTRA_OECONF:class-nativesdk = " \
+ --enable-wrpseudo-compat \
+ --disable-otmpfile \
+"
+
# Path to ${prefix}/lib/ostree/ostree-grub-generator is hardcoded on the
# do_configure stage so we do depend on it
SYSROOT_DIR = "${STAGING_DIR_TARGET}"
@@ -106,6 +118,10 @@ do_install:append:class-native() {
create_wrapper ${D}${bindir}/ostree OSTREE_GRUB2_EXEC="${STAGING_LIBDIR_NATIVE}/ostree/ostree-grub-generator"
}
+do_install:append:class-nativesdk() {
+ create_wrapper ${D}${bindir}/ostree OSTREE_GRUB2_EXEC="\$OECORE_NATIVE_SYSROOT/usr/lib/ostree/ostree-grub-generator"
+}
+
PACKAGE_BEFORE_PN = " \
${PN}-dracut \
${PN}-grub \
@@ -186,4 +202,4 @@ RRECOMMENDS:${PN} += "kernel-module-overlay"
SYSTEMD_SERVICE:${PN} = "ostree-remount.service ostree-finalize-staged.path"
SYSTEMD_SERVICE:${PN}-switchroot = "ostree-prepare-root.service"
-BBCLASSEXTEND = "native"
+BBCLASSEXTEND = "native nativesdk"