aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRandy MacLeod <randy.macleod@windriver.com>2020-01-05 11:42:57 -0500
committerKhem Raj <raj.khem@gmail.com>2020-01-06 08:24:45 -0800
commitf602e9f1e14ac2c9f0d094b9d8c7605aa6df9767 (patch)
tree886cc0108068057fb489ca80d168ab4003d305f8
parentc7062454dc235ea56b9e93cd13d7c2a297857518 (diff)
downloadmeta-openembedded-contrib-f602e9f1e14ac2c9f0d094b9d8c7605aa6df9767.tar.gz
tigervnc: update from 1.9.0 to 1.10.1
Add perl runtime dependecy since the vncserver program is and always has been a perl script. Signed-off-by: Randy MacLeod <Randy.MacLeod@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-graphics/tigervnc/tigervnc_1.10.1.bb (renamed from meta-oe/recipes-graphics/tigervnc/tigervnc_1.9.0.bb)15
1 files changed, 7 insertions, 8 deletions
diff --git a/meta-oe/recipes-graphics/tigervnc/tigervnc_1.9.0.bb b/meta-oe/recipes-graphics/tigervnc/tigervnc_1.10.1.bb
index d0ee2a50ec..16937792eb 100644
--- a/meta-oe/recipes-graphics/tigervnc/tigervnc_1.9.0.bb
+++ b/meta-oe/recipes-graphics/tigervnc/tigervnc_1.10.1.bb
@@ -3,7 +3,7 @@ HOMEPAGE = "http://www.tigervnc.com/"
LICENSE = "GPLv2+"
SECTION = "x11/utils"
DEPENDS = "xserver-xorg gnutls jpeg libxtst gettext-native fltk"
-RDEPENDS_${PN} = "chkconfig coreutils hicolor-icon-theme"
+RDEPENDS_${PN} = "chkconfig coreutils hicolor-icon-theme perl"
LIC_FILES_CHKSUM = "file://LICENCE.TXT;md5=75b02c2872421380bbd47781d2bd75d3"
@@ -15,10 +15,9 @@ REQUIRED_DISTRO_FEATURES = "x11"
inherit autotools cmake
B = "${S}"
-SRCREV = "6f2301d08e64a965ad36b401ec8dc2b24bc47075"
+SRCREV = "4739493b635372bd40a34640a719f79fa90e4dba"
-SRC_URI = "git://github.com/TigerVNC/tigervnc.git;branch=1.9-branch \
- file://0001-tigervnc-remove-includedir.patch \
+SRC_URI = "git://github.com/TigerVNC/tigervnc.git;branch=1.10-branch \
file://0002-do-not-build-tests-sub-directory.patch \
file://0003-add-missing-dynamic-library-to-FLTK_LIBRARIES.patch \
file://0004-tigervnc-add-fPIC-option-to-COMPILE_FLAGS.patch \
@@ -26,11 +25,11 @@ SRC_URI = "git://github.com/TigerVNC/tigervnc.git;branch=1.9-branch \
# Keep sync with xorg-server in oe-core
XORG_PN ?= "xorg-server"
-XORG_PV ?= "1.19.6"
+XORG_PV ?= "1.20.6"
SRC_URI += "${XORG_MIRROR}/individual/xserver/${XORG_PN}-${XORG_PV}.tar.bz2;name=xorg"
XORG_S = "${WORKDIR}/${XORG_PN}-${XORG_PV}"
-SRC_URI[xorg.md5sum] = "3e47777ff034a331aed2322b078694a8"
-SRC_URI[xorg.sha256sum] = "a732502f1db000cf36a376cd0c010ffdbf32ecdd7f1fa08ba7f5bdf9601cc197"
+SRC_URI[xorg.md5sum] = "a98170084f2c8fed480d2ff601f8a14b"
+SRC_URI[xorg.sha256sum] = "6316146304e6e8a36d5904987ae2917b5d5b195dc9fc63d67f7aca137e5a51d1"
# It is the directory containing the Xorg source for the
# machine on which you are building TigerVNC.
@@ -58,7 +57,7 @@ do_patch_xserver () {
xargs tar cf - | (cd ${XSERVER_SOURCE_DIR} && tar xf -)
cd ${XSERVER_SOURCE_DIR}
- xserverpatch="${S}/unix/xserver119.patch"
+ xserverpatch="${S}/unix/xserver120.patch"
echo "Apply $xserverpatch"
patch -p1 -b --suffix .vnc < $xserverpatch
}