aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-11-21 10:24:10 -0800
committerKhem Raj <raj.khem@gmail.com>2019-11-21 17:52:26 -0800
commit86d4131dfabdf4bca27d96de6f271565f1a3a5c6 (patch)
tree2b8a3bc530feb04091f7b6af9a3eff30e3a19395
parent80d4d7538a85123603eea3d87542c1c0433febb7 (diff)
downloadmeta-openembedded-contrib-86d4131dfabdf4bca27d96de6f271565f1a3a5c6.tar.gz
nodejs: libatomic patch should be target specific
host usually are using gcc/x86_64/aarch64 and all of them have gcc which can support atomic intrinsics, but not all of them install libatomic by default e.g. centos-7, so asking for libatomic unconditionally may not work always Signed-off-by: Khem Raj <raj.khem@gmail.com> Acked-by: Andreas Müller <schnitzeltony@gmail.com> Acked-by: Tim Orling <timothy.t.orling@linux.intel.com>
-rw-r--r--meta-oe/recipes-devtools/nodejs/nodejs_10.17.0.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-oe/recipes-devtools/nodejs/nodejs_10.17.0.bb b/meta-oe/recipes-devtools/nodejs/nodejs_10.17.0.bb
index 8c690ae7dc..e36995c258 100644
--- a/meta-oe/recipes-devtools/nodejs/nodejs_10.17.0.bb
+++ b/meta-oe/recipes-devtools/nodejs/nodejs_10.17.0.bb
@@ -18,10 +18,10 @@ COMPATIBLE_HOST_riscv32 = "null"
SRC_URI = "http://nodejs.org/dist/v${PV}/node-v${PV}.tar.xz \
file://0001-Disable-running-gyp-files-for-bundled-deps.patch \
file://0004-Make-compatibility-with-gcc-4.8.patch \
- file://0005-Link-atomic-library.patch \
file://0007-v8-don-t-override-ARM-CFLAGS.patch \
"
SRC_URI_append_class-target = " \
+ file://0005-Link-atomic-library.patch \
file://0002-Using-native-torque.patch \
"