aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Luebbe <jlu@pengutronix.de>2019-11-21 13:09:10 +0100
committerKhem Raj <raj.khem@gmail.com>2019-11-22 09:22:47 -0800
commit060ad325b654d3b8680a14a892a8061a12691a56 (patch)
tree9241d7010adc50830cd2c0c32361c446a0727288
parente2180b00b3b8fcf776c341d4b4e7bd435a3619ea (diff)
downloadmeta-openembedded-contrib-060ad325b654d3b8680a14a892a8061a12691a56.tar.gz
opensc: use pcsc-lite instead of openct by default
OpenCT upstream maintenance seems to have stopped and OpenSC upstream uses pcsc-lite by default in their configure script. Add PACKAGECONFIGs for each and select pcsc by default. As the openct package depends on pcsc-lite by itself, this avoids an unnecessary package in the default case. Signed-off-by: Jan Luebbe <jlu@pengutronix.de> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-support/opensc/opensc_0.19.0.bb9
1 files changed, 6 insertions, 3 deletions
diff --git a/meta-oe/recipes-support/opensc/opensc_0.19.0.bb b/meta-oe/recipes-support/opensc/opensc_0.19.0.bb
index bc1722e394..440859a37a 100644
--- a/meta-oe/recipes-support/opensc/opensc_0.19.0.bb
+++ b/meta-oe/recipes-support/opensc/opensc_0.19.0.bb
@@ -16,20 +16,23 @@ SRCREV = "f1691fc91fc113191c3a8aaf5facd6983334ec47"
SRC_URI = "git://github.com/OpenSC/OpenSC \
file://0001-Remove-redundant-logging.patch \
"
-DEPENDS = "openct pcsc-lite virtual/libiconv openssl"
+DEPENDS = "virtual/libiconv openssl"
S = "${WORKDIR}/git"
inherit autotools pkgconfig bash-completion
EXTRA_OECONF = " \
--disable-static \
- --enable-openct \
- --disable-pcsc \
--disable-ctapi \
--disable-doc \
"
EXTRA_OEMAKE = "DESTDIR=${D}"
+PACKAGECONFIG ??= "pcsc"
+
+PACKAGECONFIG[openct] = "--enable-openct,--disable-openct,openct"
+PACKAGECONFIG[pcsc] = "--enable-pcsc,--disable-pcsc,pcsc-lite"
+
RDEPENDS_${PN} = "readline"
FILES_${PN} += "\