aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@arm.com>2022-03-07 17:01:00 +0000
committerKhem Raj <raj.khem@gmail.com>2022-03-08 08:06:33 -0800
commit9b032a310d6a973f5381f8ebea45fb0305bb1cdc (patch)
tree33576389820efef74cade1c66678ad38f602d1a8
parent628f39c508e0dc2da465b09a2be61832227c73f2 (diff)
downloadmeta-openembedded-contrib-9b032a310d6a973f5381f8ebea45fb0305bb1cdc.tar.gz
python3-blivetgui: use setuptools_legacy
The setup.py installs to arbitrary target paths, so can't use the new bdist_wheel installation method. Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-extended/python-blivet/python3-blivetgui_2.3.0.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta-python/recipes-extended/python-blivet/python3-blivetgui_2.3.0.bb b/meta-python/recipes-extended/python-blivet/python3-blivetgui_2.3.0.bb
index 995fb49622..c26ae1fe98 100644
--- a/meta-python/recipes-extended/python-blivet/python3-blivetgui_2.3.0.bb
+++ b/meta-python/recipes-extended/python-blivet/python3-blivetgui_2.3.0.bb
@@ -16,7 +16,9 @@ SRC_URI = "git://github.com/storaged-project/blivet-gui.git;branch=master;protoc
inherit features_check
REQUIRED_DISTRO_FEATURES = "x11 systemd"
-inherit setuptools3 python3native
+inherit setuptools3_legacy python3native
+
+PIP_INSTALL_PACKAGE = "blivet_gui"
RDEPENDS:${PN} = "python3-pygobject python3 \
python3-blivet gtk+3 \