aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2022-03-07 19:46:41 +0800
committerKhem Raj <raj.khem@gmail.com>2022-03-08 08:06:33 -0800
commit41d2f43afee4994468a030ed9b746213b838e406 (patch)
treea40f6b6aa2157f3582d11c743eca538e0b626018
parent398f65946963bb341e7261b758a6f22ca0d23e32 (diff)
downloadmeta-openembedded-contrib-41d2f43afee4994468a030ed9b746213b838e406.tar.gz
python3-lxml: upgrade 4.7.1 -> 4.8.0
0001-setupinfo.py-check-the-return-value.patch removed since it's included in 4.8.0. Changelog: ========= Features added -------------- * GH#337: Path-like objects are now supported throughout the API instead of just strings. Patch by Henning Janssen. * The ''ElementMaker'' now supports ''QName'' values as tags, which always override the default namespace of the factory. Bugs fixed ---------- * GH#338: In lxml.objectify, the XSI float annotation "nan" and "inf" were spelled in lower case, whereas XML Schema datatypes define them as "NaN" and "INF" respectively. Patch by Tobias Deiminger. Other changes ------------- * Built with Cython 0.29.28. Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-lxml/0001-setupinfo.py-check-the-return-value.patch46
-rw-r--r--meta-python/recipes-devtools/python/python3-lxml_4.8.0.bb (renamed from meta-python/recipes-devtools/python/python3-lxml_4.7.1.bb)6
2 files changed, 2 insertions, 50 deletions
diff --git a/meta-python/recipes-devtools/python/python3-lxml/0001-setupinfo.py-check-the-return-value.patch b/meta-python/recipes-devtools/python/python3-lxml/0001-setupinfo.py-check-the-return-value.patch
deleted file mode 100644
index 7d9121846f..0000000000
--- a/meta-python/recipes-devtools/python/python3-lxml/0001-setupinfo.py-check-the-return-value.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-From 057872fa40e061100d61117cee5c3413ef2e40fc Mon Sep 17 00:00:00 2001
-From: Mingli Yu <mingli.yu@windriver.com>
-Date: Thu, 20 Jan 2022 15:18:20 +0800
-Subject: [PATCH] setupinfo.py: check the return value
-
-Use the return value altogether to check the subprocess execute
-successfully or not as in some case it will print some noise
-message though run successfully as below.
-
- # python
- Python 3.8.10 (default, Nov 26 2021, 20:14:08)
- [GCC 9.3.0] on linux
- Type "help", "copyright", "credits" or "license" for more information.
- >>> import subprocess
- >>> cmd = "pkg-config --modversion libxml-2.0"
- >>> p = subprocess.Popen(cmd, shell=True,stdout=subprocess.PIPE, stderr=subprocess.PIPE)
- >>> stdout_data, errors = p.communicate()
- >>> print(stdout_data)
- b'2.9.12\n'
- >>> print(errors)
- b'do_ypcall: clnt_call: RPC: Unable to send; errno = Network is unreachable\n'
- >>>
-
-Upstream-Status: Submitted [https://github.com/lxml/lxml/pull/336]
-
-Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
----
- setupinfo.py | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/setupinfo.py b/setupinfo.py
-index 8c2a36fb..c1247c6d 100644
---- a/setupinfo.py
-+++ b/setupinfo.py
-@@ -365,7 +365,7 @@ def run_command(cmd, *args):
- stdout=subprocess.PIPE, stderr=subprocess.PIPE)
- stdout_data, errors = p.communicate()
-
-- if errors:
-+ if p.returncode != 0 and errors:
- return ''
- return decode_input(stdout_data).strip()
-
---
-2.17.1
-
diff --git a/meta-python/recipes-devtools/python/python3-lxml_4.7.1.bb b/meta-python/recipes-devtools/python/python3-lxml_4.8.0.bb
index f3b7e0c6cd..c4d4df383a 100644
--- a/meta-python/recipes-devtools/python/python3-lxml_4.7.1.bb
+++ b/meta-python/recipes-devtools/python/python3-lxml_4.8.0.bb
@@ -18,11 +18,9 @@ LIC_FILES_CHKSUM = "file://LICENSES.txt;md5=e4c045ebad958ead4b48008f70838403 \
DEPENDS += "libxml2 libxslt"
-SRC_URI[sha256sum] = "a1613838aa6b89af4ba10a0f3a972836128801ed008078f8c1244e65958f1b24"
+SRC_URI[sha256sum] = "f63f62fc60e6228a4ca9abae28228f35e1bd3ce675013d1dfb828688d50c6e23"
-SRC_URI += " \
- file://0001-setupinfo.py-check-the-return-value.patch \
-"
+SRC_URI += "${PYPI_SRC_URI}"
inherit pkgconfig pypi setuptools3
# {standard input}: Assembler messages: