aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2017-12-15 15:21:58 -0500
committerArmin Kuster <akuster808@gmail.com>2018-02-03 19:42:41 -0800
commit2019c200a6e8fd1c4bcdd04994b3e35cd2f41da7 (patch)
tree3a97c50bee0576d32d79c69597ca69edb54ac5b8
parent5807656d8b5a8c690cf3c83df0fbd520a0dfd450 (diff)
downloadmeta-openembedded-contrib-2019c200a6e8fd1c4bcdd04994b3e35cd2f41da7.tar.gz
python-incremental: add an initial recipe for version 17.5.0
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python-incremental.inc14
-rw-r--r--meta-python/recipes-devtools/python/python-incremental_17.5.0.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-incremental_17.5.0.bb2
3 files changed, 18 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-incremental.inc b/meta-python/recipes-devtools/python/python-incremental.inc
new file mode 100644
index 0000000000..3675458688
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-incremental.inc
@@ -0,0 +1,14 @@
+DESCRIPTION = "Incremental is a small library that versions your Python projects"
+HOMEPAGE = "https://github.com/twisted/incremental"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=6ca9b07f08e2c72d48c74d363d1e0e15"
+
+SRC_URI[md5sum] = "602746e0d438e075a5a9e0678140bba2"
+SRC_URI[sha256sum] = "7b751696aaf36eebfab537e458929e194460051ccad279c72b755a167eebd4b3"
+
+inherit pypi
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-twisted \
+ ${PYTHON_PN}-click \
+"
diff --git a/meta-python/recipes-devtools/python/python-incremental_17.5.0.bb b/meta-python/recipes-devtools/python/python-incremental_17.5.0.bb
new file mode 100644
index 0000000000..139ac0c522
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-incremental_17.5.0.bb
@@ -0,0 +1,2 @@
+inherit setuptools
+require python-incremental.inc
diff --git a/meta-python/recipes-devtools/python/python3-incremental_17.5.0.bb b/meta-python/recipes-devtools/python/python3-incremental_17.5.0.bb
new file mode 100644
index 0000000000..0f04df4a67
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-incremental_17.5.0.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-incremental.inc