aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBartosz Golaszewski <bgolaszewski@baylibre.com>2019-09-23 18:47:22 +0200
committerKhem Raj <raj.khem@gmail.com>2019-09-23 09:55:55 -0700
commit6bcab95d51e1426cc3f5d9e6b2cd3054e07089e1 (patch)
treeb7e165ebddbd2a20e9088e036ccb3b92fb56c8c4
parent97e769fc46734462c41a53836b0597a6c87ee047 (diff)
downloadmeta-openembedded-contrib-6bcab95d51e1426cc3f5d9e6b2cd3054e07089e1.tar.gz
python3-dtschema: new package
This adds a recipe for dtschema package developed by Rob Herring for easy validation of YAML device-tree files in the linux kernel. The version is current git as the only release so far - v0.1 - is old and doesn't work with kernel's dt_binding_check make target. Signed-off-by: Bartosz Golaszewski <bgolaszewski@baylibre.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-dt-schema_git.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-dt-schema_git.bb b/meta-python/recipes-devtools/python/python3-dt-schema_git.bb
new file mode 100644
index 0000000000..06a9012ca4
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-dt-schema_git.bb
@@ -0,0 +1,15 @@
+SUMMARY = "Tooling for devicetree validation using YAML and jsonschema"
+AUTHOR = "Rob Herring"
+
+LICENSE = "BSD-2-Clause"
+LIC_FILES_CHKSUM = "file://setup.py;beginline=2;endline=3;md5=c795d4924c5f739424fa8d9b569c6659"
+
+inherit setuptools3
+
+SRC_URI = "git://github.com/robherring/dt-schema.git"
+SRCREV = "5009e47c1c76e48871f5988e08dad61f3c91196b"
+PV = "0.1+git${SRCPV}"
+
+S = "${WORKDIR}/git"
+
+RDEPENDS_${PN} = "python3-jsonschema python3-ruamel-yaml"