aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2019-09-25 11:43:42 +0800
committerRobert Yang <liezhi.yang@windriver.com>2019-09-25 16:41:47 +0800
commitafc2928a9d44cbc743600bbbb18f02b9f73a3e18 (patch)
treeafbffdb727bccd8d384575a068107a2d8445f858
parent1c900ec3f7272b972d3713985fc977b52b0a774d (diff)
downloadmeta-openembedded-contrib-afc2928a9d44cbc743600bbbb18f02b9f73a3e18.tar.gz
fuse: Fix installed-vs-shipped for nativesdk
There are two problems: * The /dev is installed to '${D}/dev', not '${D}${base_prefix}' * The /etc is installed ${D}, but should be ${D}${sysconfdir} It works for target is because target's base_prefix is NULL, but it isn't work for native or nativesdk. Fixed: $ bitbake nativesdk-fuse ERROR: nativesdk-fuse-2.9.9-r0 do_package: QA Issue: nativesdk-fuse: Files/directories were installed but not shipped in any package: /dev /etc /etc/init.d /etc/udev /etc/init.d/fuse /etc/udev/rules.d /etc/udev/rules.d/99-fuse.rules Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
-rw-r--r--meta-filesystems/recipes-support/fuse/fuse_2.9.9.bb8
1 files changed, 7 insertions, 1 deletions
diff --git a/meta-filesystems/recipes-support/fuse/fuse_2.9.9.bb b/meta-filesystems/recipes-support/fuse/fuse_2.9.9.bb
index c83e7f6d32..95e870691c 100644
--- a/meta-filesystems/recipes-support/fuse/fuse_2.9.9.bb
+++ b/meta-filesystems/recipes-support/fuse/fuse_2.9.9.bb
@@ -54,7 +54,7 @@ do_configure_prepend() {
}
do_install_append() {
- rm -rf ${D}${base_prefix}/dev
+ rm -rf ${D}/dev
# systemd class remove the sysv_initddir only if systemd_system_unitdir
# contains anything, but it's not needed if sysvinit is not in DISTRO_FEATURES
@@ -69,4 +69,10 @@ do_install_append() {
fi
}
+do_install_append_class-nativesdk() {
+ install -d ${D}${sysconfdir}
+ mv ${D}/etc/* ${D}${sysconfdir}/
+ rmdir ${D}/etc
+}
+
BBCLASSEXTEND = "native nativesdk"