aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRicardo Salveti <ricardo@foundries.io>2019-09-17 16:09:12 -0300
committerKhem Raj <raj.khem@gmail.com>2019-09-17 20:47:11 -0700
commit34709e2d5945950f06d0ea349bb4e6ccefd58781 (patch)
tree5f81591a20187d6224dc5e17daf084e25439f680
parent53e12287ba4421dec5a46e007b14e4afead4b094 (diff)
downloadmeta-openembedded-contrib-34709e2d5945950f06d0ea349bb4e6ccefd58781.tar.gz
python-pyrsistent: add recipe
Persistent/immutable/functional data structures for python, now required by python-jsonschema. Signed-off-by: Ricardo Salveti <ricardo@foundries.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python-pyrsistent.inc13
-rw-r--r--meta-python/recipes-devtools/python/python-pyrsistent_0.15.4.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-pyrsistent_0.15.4.bb2
3 files changed, 17 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-pyrsistent.inc b/meta-python/recipes-devtools/python/python-pyrsistent.inc
new file mode 100644
index 0000000000..2add037de8
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pyrsistent.inc
@@ -0,0 +1,13 @@
+SUMMARY = "Persistent/Immutable/Functional data structures for Python"
+HOMEPAGE = "https://github.com/tobgu/pyrsistent"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENCE.mit;md5=ca574f2891cf528b3e7a2ee570337e7c"
+
+SRC_URI[md5sum] = "0298efae86e009e24136d39dc8b2d33e"
+SRC_URI[sha256sum] = "34b47fa169d6006b32e99d4b3c4031f155e6e68ebcc107d6454852e8e0ee6533"
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-six \
+"
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python-pyrsistent_0.15.4.bb b/meta-python/recipes-devtools/python/python-pyrsistent_0.15.4.bb
new file mode 100644
index 0000000000..832eb80381
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pyrsistent_0.15.4.bb
@@ -0,0 +1,2 @@
+inherit pypi setuptools
+require python-pyrsistent.inc
diff --git a/meta-python/recipes-devtools/python/python3-pyrsistent_0.15.4.bb b/meta-python/recipes-devtools/python/python3-pyrsistent_0.15.4.bb
new file mode 100644
index 0000000000..2e567e9f9c
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pyrsistent_0.15.4.bb
@@ -0,0 +1,2 @@
+inherit pypi setuptools3
+require python-pyrsistent.inc