aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2015-11-19 23:52:47 -0800
committerRobert Yang <liezhi.yang@windriver.com>2015-11-20 01:35:50 -0800
commite5a41eb40fd626200107e9f8902fd0250e4022ad (patch)
tree3d3b718d1b8a5b597a6681410c60f780ec7e75d2
parentcc309828ad053cfd2d052568d21ddbb5ceebee79 (diff)
downloadmeta-openembedded-contrib-e5a41eb40fd626200107e9f8902fd0250e4022ad.tar.gz
dracut: fix host-user-contaminated
Fixed: dracut-043+giteab03540cd695d940062af5b55c02e8829aaa526: dracut: /dracut/usr/lib/dracut/modules.d/99img-lib/img-lib.sh is owned by uid 15220, which is the same as the user running bitbake. This may be due to host contamination [host-user-contaminated] lib32-dracut-043+giteab03540cd695d940062af5b55c02e8829aaa526: lib32-dracut: /lib32-dracut/usr/lib/dracut/modules.d/99img-lib/img-lib.sh is owned by uid 15220, which is the same as the user running bitbake. This may be due to host contamination [host-user-contaminated] Its Makefile uses cp -arx to install modules.d, so fix the owner to root:root Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
-rw-r--r--meta-initramfs/recipes-devtools/dracut/dracut_git.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta-initramfs/recipes-devtools/dracut/dracut_git.bb b/meta-initramfs/recipes-devtools/dracut/dracut_git.bb
index 91a83214db..e026da7101 100644
--- a/meta-initramfs/recipes-devtools/dracut/dracut_git.bb
+++ b/meta-initramfs/recipes-devtools/dracut/dracut_git.bb
@@ -36,6 +36,9 @@ do_configure() {
do_install() {
oe_runmake install DESTDIR=${D}
+ # Its Makefile uses cp -arx to install modules.d, so fix the owner
+ # to root:root
+ chown -R root:root ${D}/${prefix}/lib/dracut/modules.d
}
PACKAGES =+ "${PN}-bash-completion"