aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjabdoa2 <jabdoa2@users.noreply.github.com>2020-12-31 17:48:11 +0100
committerArmin Kuster <akuster808@gmail.com>2021-01-14 18:38:03 -0800
commitaf0c3a62d6faba0f0a9d8cc09e8b72845575346b (patch)
tree512e4d522162a527cff6a65b3cf7cfb8cafcda68
parentac6bc96e7da6b3c9d5b9c9272b487a926fbb462e (diff)
downloadmeta-openembedded-contrib-af0c3a62d6faba0f0a9d8cc09e8b72845575346b.tar.gz
libsdl2-mixer: Fix ogg/vorbis support in libsdl2-mixer
Remove --enable-music-ogg-tremor as it broke vorbis support: checking tremor/ivorbisfile.h usability... no checking tremor/ivorbisfile.h presence... no checking for tremor/ivorbisfile.h... no checking for ov_open_callbacks in -lvorbisidec... no configure: WARNING: *** Unable to find Ogg Vorbis Tremor library (http://www.xiph.org/) configure: WARNING: Ogg Vorbis support disabled With this change: checking vorbis/vorbisfile.h usability... yes checking vorbis/vorbisfile.h presence... yes checking for vorbis/vorbisfile.h... yes checking for ov_open_callbacks in -lvorbisfile... yes -- dynamic libvorbisfile -> libvorbisfile.so.3 Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry picked from commit 074c7d9a1ebb86674f02d8a5545e1ed54f6d87fe) Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-graphics/libsdl/libsdl2-mixer_2.0.4.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-oe/recipes-graphics/libsdl/libsdl2-mixer_2.0.4.bb b/meta-oe/recipes-graphics/libsdl/libsdl2-mixer_2.0.4.bb
index aa246f9995..77e50d3841 100644
--- a/meta-oe/recipes-graphics/libsdl/libsdl2-mixer_2.0.4.bb
+++ b/meta-oe/recipes-graphics/libsdl/libsdl2-mixer_2.0.4.bb
@@ -14,7 +14,7 @@ S = "${WORKDIR}/SDL2_mixer-${PV}"
inherit autotools-brokensep pkgconfig
EXTRA_AUTORECONF += "--include=acinclude"
-EXTRA_OECONF = "--disable-music-mp3 --enable-music-ogg --enable-music-ogg-tremor LIBS=-L${STAGING_LIBDIR}"
+EXTRA_OECONF = "--disable-music-mp3 --enable-music-ogg LIBS=-L${STAGING_LIBDIR}"
PACKAGECONFIG[mad] = "--enable-music-mp3-mad-gpl,--disable-music-mp3-mad-gpl,libmad"