aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoland Hieber <rhi@pengutronix.de>2020-12-01 15:16:57 +0100
committerArmin Kuster <akuster808@gmail.com>2020-12-10 08:43:27 -0800
commit3e84d4caabfd21ff68837d875e6a7f00b63a9c45 (patch)
treecfc84653296d4bf8f795676c2b714c318e4c9181
parent0c158538eda581450dbdb5762d668721ba7fe4f0 (diff)
downloadmeta-openembedded-contrib-3e84d4caabfd21ff68837d875e6a7f00b63a9c45.tar.gz
pcsc-lite: provide pcsc-lite-lib-native explicitly for native build
Commits e2180b00b3b8fcf776c3 and 8edd760e66b48e411d2a added support for native builds for the opensc and pcsc-lite recipes, but building opensc-native fails after commit 40b3a5123120da0e4586 (2019-12-04, "opensc: fix RDEPENDS in pcsc PACKAGECONFIG"): ERROR: Required build target 'opensc-native' has no buildable providers. Missing or unbuildable dependency chain was: ['opensc-native', 'pcsc-lite-lib-native'] The commit in question is correct for target builds, but native builds don't have packages. The -lib part is also provided along with pcsc-lite-native, and there is no pcsc-lite-lib-native package. Ideally we would fix this in the opensc recipe. However, using syntax like "PACKAGECONFIG_class-native[pcsc]" in the opensc recipe is apparently not possible to overwrite the dependency for a native build, and using RDEPENDS_remove has no effect either – apparently dependencies from PACKAGECONFIG are added after RDEPENDS_remove is evaluated. Therefore let pcsc-lite provide the missing package name for native builds, even if fixing this unrelated package is not the most elegant solution. Fixes: 40b3a5123120da0e4586 (2019-12-04, "opensc: fix RDEPENDS in pcsc PACKAGECONFIG") Signed-off-by: Roland Hieber <rhi@pengutronix.de> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-support/pcsc-lite/pcsc-lite_1.8.26.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/pcsc-lite/pcsc-lite_1.8.26.bb b/meta-oe/recipes-support/pcsc-lite/pcsc-lite_1.8.26.bb
index 91d77ac938..04989fb740 100644
--- a/meta-oe/recipes-support/pcsc-lite/pcsc-lite_1.8.26.bb
+++ b/meta-oe/recipes-support/pcsc-lite/pcsc-lite_1.8.26.bb
@@ -36,6 +36,7 @@ PACKAGES = "${PN} ${PN}-dbg ${PN}-dev ${PN}-lib ${PN}-doc ${PN}-spy ${PN}-spy-de
RRECOMMENDS_${PN} = "ccid"
RRECOMMENDS_${PN}_class-native = ""
+RPROVIDES_${PN}_class-native += "pcsc-lite-lib-native"
FILES_${PN} = "${sbindir}/pcscd"
FILES_${PN}-lib = "${libdir}/libpcsclite*${SOLIBS}"