aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2020-04-04 13:12:43 -0400
committerKhem Raj <raj.khem@gmail.com>2020-04-05 10:38:13 -0700
commit1dbb1c6653d41a646ae2a483a56830b2890baa77 (patch)
tree80559b4e848b81899d8f97a4fe07777abf5755ad
parent2aa63fd4e470ffc2aa2c8d17abc0766588d10d5e (diff)
downloadmeta-openembedded-contrib-1dbb1c6653d41a646ae2a483a56830b2890baa77.tar.gz
python-simplejson: consolidate inc and bb files into a single bb file
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python-simplejson.inc25
-rw-r--r--meta-python/recipes-devtools/python/python3-simplejson_3.17.0.bb27
2 files changed, 25 insertions, 27 deletions
diff --git a/meta-python/recipes-devtools/python/python-simplejson.inc b/meta-python/recipes-devtools/python/python-simplejson.inc
deleted file mode 100644
index 1a8d390e4b..0000000000
--- a/meta-python/recipes-devtools/python/python-simplejson.inc
+++ /dev/null
@@ -1,25 +0,0 @@
-SUMMARY = "Simple, fast, extensible JSON encoder/decoder for Python"
-HOMEPAGE = "http://cheeseshop.python.org/pypi/simplejson"
-
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=c6338d7abd321c0b50a2a547e441c52e"
-
-SRC_URI[md5sum] = "8a5ed75c367b90fedc3d685742e2a1c7"
-SRC_URI[sha256sum] = "2b4b2b738b3b99819a17feaf118265d0753d5536049ea570b3c43b51c4701e81"
-
-inherit pypi
-
-RDEPENDS_${PN} += "\
- ${PYTHON_PN}-io \
- ${PYTHON_PN}-netserver \
- ${PYTHON_PN}-numbers \
-"
-
-PACKAGES =+ "${PN}-tests"
-RDEPENDS_${PN}-tests = "${PN} ${PYTHON_PN}-unittest"
-FILES_${PN}-tests+= " \
- ${PYTHON_SITEPACKAGES_DIR}/simplejson/tests \
- ${PYTHON_SITEPACKAGES_DIR}/simplejson/tool.py* \
-"
-
-BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python3-simplejson_3.17.0.bb b/meta-python/recipes-devtools/python/python3-simplejson_3.17.0.bb
index 38f406c5de..b76ae5299a 100644
--- a/meta-python/recipes-devtools/python/python3-simplejson_3.17.0.bb
+++ b/meta-python/recipes-devtools/python/python3-simplejson_3.17.0.bb
@@ -1,2 +1,25 @@
-inherit setuptools3
-require python-simplejson.inc
+SUMMARY = "Simple, fast, extensible JSON encoder/decoder for Python"
+HOMEPAGE = "http://cheeseshop.python.org/pypi/simplejson"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=c6338d7abd321c0b50a2a547e441c52e"
+
+SRC_URI[md5sum] = "8a5ed75c367b90fedc3d685742e2a1c7"
+SRC_URI[sha256sum] = "2b4b2b738b3b99819a17feaf118265d0753d5536049ea570b3c43b51c4701e81"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-io \
+ ${PYTHON_PN}-netserver \
+ ${PYTHON_PN}-numbers \
+"
+
+PACKAGES =+ "${PN}-tests"
+RDEPENDS_${PN}-tests = "${PN} ${PYTHON_PN}-unittest"
+FILES_${PN}-tests+= " \
+ ${PYTHON_SITEPACKAGES_DIR}/simplejson/tests \
+ ${PYTHON_SITEPACKAGES_DIR}/simplejson/tool.py* \
+"
+
+BBCLASSEXTEND = "native nativesdk"