aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnkit Navik <ankit.tarot@gmail.com>2019-05-02 21:13:17 +0530
committerKhem Raj <raj.khem@gmail.com>2019-05-03 10:04:45 -0700
commit52ab4b5323fb6b483f327fdf5d118e23d8ca3574 (patch)
tree6c8b4028e72e6b755a377f4e3ba59a5113d2da11
parent0a1c33dde337084a8d691163454bf2e344550aca (diff)
downloadmeta-openembedded-contrib-52ab4b5323fb6b483f327fdf5d118e23d8ca3574.tar.gz
libnfc: Initial recipe for Near Field Communication library.
Add generic recipe for Near Field Communication (NFC) library. It also includes testing scheme which is not extensive but elements are already in place. Signed-off-by: Ankit Navik <ankit.tarot@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-core/libnfc/libnfc_git.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta-oe/recipes-core/libnfc/libnfc_git.bb b/meta-oe/recipes-core/libnfc/libnfc_git.bb
new file mode 100644
index 0000000000..d00733bf58
--- /dev/null
+++ b/meta-oe/recipes-core/libnfc/libnfc_git.bb
@@ -0,0 +1,14 @@
+SUMMARY = "Platform independent Near Field Communication (NFC) library"
+DESCRIPTION = "libnfc is a library which allows userspace application access \
+to NFC devices."
+LICENSE = "LGPLv3"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b52f2d57d10c4f7ee67a7eb9615d5d24"
+SECTION = "libs"
+
+inherit autotools pkgconfig
+
+S = "${WORKDIR}/git"
+SRCREV = "c42e2502d4627d3ea62f83c32677b100bb3cebdc"
+SRC_URI = "git://github.com/nfc-tools/libnfc.git"
+
+DEPENDS = "libusb"