aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGary S. Robertson <gary.robertson@linaro.org>2014-11-24 16:59:14 -0600
committerMartin Jansa <Martin.Jansa@gmail.com>2014-12-10 13:33:28 +0100
commitb52a206e1df067e1f0921efc115c977845903d0a (patch)
tree7afae22a8ff24860474e203faddb0f8ba51bf354
parentb66a7ded8f341bebe4fdc9ac0351afcf22ac0d5c (diff)
downloadmeta-openembedded-contrib-b52a206e1df067e1f0921efc115c977845903d0a.tar.gz
libhugetlbfs: Make cross-devel recognize all ix86 arches
In a non-native cross-development scenario, the Makefile only recognized i386 or x86_64 PC architectures. Extended this to also recognize i486, i586, and i686 Upstream Status: Accepted but not yet applied by libhugetlbfs project Signed-off-by: Gary S. Robertson <gary.robertson@linaro.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-benchmark/libhugetlbfs/files/0001-Makefile-Recognize-all-ix86-arches.patch32
-rw-r--r--meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb1
2 files changed, 33 insertions, 0 deletions
diff --git a/meta-oe/recipes-benchmark/libhugetlbfs/files/0001-Makefile-Recognize-all-ix86-arches.patch b/meta-oe/recipes-benchmark/libhugetlbfs/files/0001-Makefile-Recognize-all-ix86-arches.patch
new file mode 100644
index 0000000000..2718275112
--- /dev/null
+++ b/meta-oe/recipes-benchmark/libhugetlbfs/files/0001-Makefile-Recognize-all-ix86-arches.patch
@@ -0,0 +1,32 @@
+From a0166583ba5f7b6a6d2de434f633126fb12c9d29 Mon Sep 17 00:00:00 2001
+From: "Gary S. Robertson" <gary.robertson@linaro.org>
+Date: Wed, 24 Sep 2014 15:27:31 -0500
+Subject: [PATCH] Makefile: Recognize all ix86 arches
+
+In a non-native build scenario, the makefile
+only recognized i386 or x86_64 arches. Added support
+to recognize i486, i586, i686.
+
+Upstream Status: Accepted by libhugetlbfs project
+
+Signed-off-by: Gary S. Robertson <gary.robertson@linaro.org>
+---
+ Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile b/Makefile
+index 91502e1..0bfaee8 100644
+--- a/Makefile
++++ b/Makefile
+@@ -71,7 +71,7 @@ ELF64 = aarch64elf
+ TMPLIB64 = lib64
+ CUSTOM_LDSCRIPTS = no
+ else
+-ifeq ($(ARCH),i386)
++ifneq (,$(filter i386 i486 i586 i686,$(ARCH)))
+ CC32 = $(CC)
+ ELF32 = elf_i386
+ TMPLIB32 = lib
+--
+1.7.9.5
+
diff --git a/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb b/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb
index c2262eaaa5..c90621703d 100644
--- a/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb
+++ b/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb
@@ -19,6 +19,7 @@ SRC_URI = "git://git.code.sf.net/p/libhugetlbfs/code \
file://0001-aarch64-fix-page-size-not-properly-computed.patch \
file://0001-replace-lib-lib64-hardcoded-values-by-LIBDIR32-LIBDI.patch \
file://0001-Extend-arm32-support-to-include-BE-variants.patch \
+ file://0001-Makefile-Recognize-all-ix86-arches.patch \
"
S = "${WORKDIR}/git"