aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2017-09-18 16:58:33 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2017-09-22 22:50:44 +0000
commit8d96e46f7c141ab2b632169037d06beca17e5d0b (patch)
tree5ca976dac88bb992bb75e8bec4e1f8f55c141c0a
parent042972dfff8eebadee55a9c98ce5deb010e5d45b (diff)
downloadmeta-openembedded-contrib-8d96e46f7c141ab2b632169037d06beca17e5d0b.tar.gz
python-lxml: update to version 4.0.0
remove obsolete patch Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python-lxml.inc4
-rw-r--r--meta-python/recipes-devtools/python/python-lxml/0001-lxml.etree-Add-empty-variadic-argument.patch40
-rw-r--r--meta-python/recipes-devtools/python/python-lxml_3.8.0.bb6
-rw-r--r--meta-python/recipes-devtools/python/python-lxml_4.0.0.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-lxml/0001-lxml.etree-Add-empty-variadic-argument.patch40
-rw-r--r--meta-python/recipes-devtools/python/python3-lxml_3.8.0.bb6
-rw-r--r--meta-python/recipes-devtools/python/python3-lxml_4.0.0.bb2
7 files changed, 6 insertions, 94 deletions
diff --git a/meta-python/recipes-devtools/python/python-lxml.inc b/meta-python/recipes-devtools/python/python-lxml.inc
index c6ff160f8c..04abe46d56 100644
--- a/meta-python/recipes-devtools/python/python-lxml.inc
+++ b/meta-python/recipes-devtools/python/python-lxml.inc
@@ -18,8 +18,8 @@ LIC_FILES_CHKSUM = "file://LICENSES.txt;md5=e4c045ebad958ead4b48008f70838403 \
DEPENDS += "libxml2 libxslt"
-SRC_URI[md5sum] = "e54e2fae44d684d6b9c636fe189e93ff"
-SRC_URI[sha256sum] = "736f72be15caad8116891eb6aa4a078b590d231fdc63818c40c21624ac71db96"
+SRC_URI[md5sum] = "c30d7e752cc909c1c0c40bd34153443a"
+SRC_URI[sha256sum] = "f7bc9f702500e205b1560d620f14015fec76dcd6f9e889a946a2ddcc3c344fd0"
DISTUTILS_BUILD_ARGS += " \
--with-xslt-config='pkg-config libxslt' \
diff --git a/meta-python/recipes-devtools/python/python-lxml/0001-lxml.etree-Add-empty-variadic-argument.patch b/meta-python/recipes-devtools/python/python-lxml/0001-lxml.etree-Add-empty-variadic-argument.patch
deleted file mode 100644
index efaecd69c6..0000000000
--- a/meta-python/recipes-devtools/python/python-lxml/0001-lxml.etree-Add-empty-variadic-argument.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-From f8d2c3394767025b3b27b71248b3ecb50480cde7 Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Thu, 13 Apr 2017 17:10:45 -0700
-Subject: [PATCH] lxml.etree: Add empty variadic argument
-
-format checker says that argument 4 is a printf formatted argument
-but there is no more arguments to follow
-
-Fixes libxslt format warnings
-
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- src/lxml/lxml.etree.c | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/src/lxml/lxml.etree.c b/src/lxml/lxml.etree.c
-index d482091..faab06c 100644
---- a/src/lxml/lxml.etree.c
-+++ b/src/lxml/lxml.etree.c
-@@ -186086,7 +186086,7 @@ static void __pyx_f_4lxml_5etree__callExtensionElement(xsltTransformContext *__p
- * except:
- */
- __pyx_t_26 = __Pyx_PyObject_AsString(__pyx_v_message); if (unlikely((!__pyx_t_26) && PyErr_Occurred())) __PYX_ERR(19, 228, __pyx_L18_except_error)
-- xsltTransformError(__pyx_v_c_ctxt, NULL, __pyx_v_c_inst_node, __pyx_t_26);
-+ xsltTransformError(__pyx_v_c_ctxt, NULL, __pyx_v_c_inst_node, __pyx_t_26, "");
-
- /* "src/lxml/xsltext.pxi":229
- * c_inst_node.name, _cstr(e))
-@@ -186136,7 +186136,7 @@ static void __pyx_f_4lxml_5etree__callExtensionElement(xsltTransformContext *__p
- * except:
- */
- __pyx_t_26 = __Pyx_PyObject_AsString(__pyx_v_message); if (unlikely((!__pyx_t_26) && PyErr_Occurred())) __PYX_ERR(19, 234, __pyx_L18_except_error)
-- xsltTransformError(__pyx_v_c_ctxt, NULL, __pyx_v_c_inst_node, __pyx_t_26);
-+ xsltTransformError(__pyx_v_c_ctxt, NULL, __pyx_v_c_inst_node, __pyx_t_26, "");
-
- /* "src/lxml/xsltext.pxi":235
- * "Error executing extension element '%s'", c_inst_node.name)
---
-2.12.2
-
diff --git a/meta-python/recipes-devtools/python/python-lxml_3.8.0.bb b/meta-python/recipes-devtools/python/python-lxml_3.8.0.bb
deleted file mode 100644
index 5c93a3f841..0000000000
--- a/meta-python/recipes-devtools/python/python-lxml_3.8.0.bb
+++ /dev/null
@@ -1,6 +0,0 @@
-inherit setuptools
-require python-lxml.inc
-
-SRC_URI = "${PYPI_SRC_URI} \
- file://0001-lxml.etree-Add-empty-variadic-argument.patch \
- "
diff --git a/meta-python/recipes-devtools/python/python-lxml_4.0.0.bb b/meta-python/recipes-devtools/python/python-lxml_4.0.0.bb
new file mode 100644
index 0000000000..81ccb12d87
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-lxml_4.0.0.bb
@@ -0,0 +1,2 @@
+inherit setuptools
+require python-lxml.inc
diff --git a/meta-python/recipes-devtools/python/python3-lxml/0001-lxml.etree-Add-empty-variadic-argument.patch b/meta-python/recipes-devtools/python/python3-lxml/0001-lxml.etree-Add-empty-variadic-argument.patch
deleted file mode 100644
index bb012dc446..0000000000
--- a/meta-python/recipes-devtools/python/python3-lxml/0001-lxml.etree-Add-empty-variadic-argument.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-From 36e64cf2f0676ee422c1fd41456967f3015b2fa3 Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Thu, 13 Apr 2017 17:10:45 -0700
-Subject: [PATCH] lxml.etree: Add empty variadic argument
-
-format checker says that argument 4 is a printf formatted argument
-but there is no more arguments to follow
-
-Fixes libxslt format warnings
-
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- src/lxml/lxml.etree.c | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/src/lxml/lxml.etree.c b/src/lxml/lxml.etree.c
-index d482091..faab06c 100644
---- a/src/lxml/lxml.etree.c
-+++ b/src/lxml/lxml.etree.c
-@@ -186086,7 +186086,7 @@ static void __pyx_f_4lxml_5etree__callExtensionElement(xsltTransformContext *__p
- * except:
- */
- __pyx_t_26 = __Pyx_PyObject_AsString(__pyx_v_message); if (unlikely((!__pyx_t_26) && PyErr_Occurred())) __PYX_ERR(19, 228, __pyx_L18_except_error)
-- xsltTransformError(__pyx_v_c_ctxt, NULL, __pyx_v_c_inst_node, __pyx_t_26);
-+ xsltTransformError(__pyx_v_c_ctxt, NULL, __pyx_v_c_inst_node, __pyx_t_26, "");
-
- /* "src/lxml/xsltext.pxi":229
- * c_inst_node.name, _cstr(e))
-@@ -186136,7 +186136,7 @@ static void __pyx_f_4lxml_5etree__callExtensionElement(xsltTransformContext *__p
- * except:
- */
- __pyx_t_26 = __Pyx_PyObject_AsString(__pyx_v_message); if (unlikely((!__pyx_t_26) && PyErr_Occurred())) __PYX_ERR(19, 234, __pyx_L18_except_error)
-- xsltTransformError(__pyx_v_c_ctxt, NULL, __pyx_v_c_inst_node, __pyx_t_26);
-+ xsltTransformError(__pyx_v_c_ctxt, NULL, __pyx_v_c_inst_node, __pyx_t_26, "");
-
- /* "src/lxml/xsltext.pxi":235
- * "Error executing extension element '%s'", c_inst_node.name)
---
-2.12.2
-
diff --git a/meta-python/recipes-devtools/python/python3-lxml_3.8.0.bb b/meta-python/recipes-devtools/python/python3-lxml_3.8.0.bb
deleted file mode 100644
index 8b13d2dd2c..0000000000
--- a/meta-python/recipes-devtools/python/python3-lxml_3.8.0.bb
+++ /dev/null
@@ -1,6 +0,0 @@
-inherit setuptools3
-require python-lxml.inc
-
-SRC_URI = "${PYPI_SRC_URI} \
- file://0001-lxml.etree-Add-empty-variadic-argument.patch \
- "
diff --git a/meta-python/recipes-devtools/python/python3-lxml_4.0.0.bb b/meta-python/recipes-devtools/python/python3-lxml_4.0.0.bb
new file mode 100644
index 0000000000..ff4bc7faad
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-lxml_4.0.0.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-lxml.inc