aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBian Naimeng <biannm@cn.fujitsu.com>2014-12-31 16:22:06 +0800
committerJoe MacDonald <joe_macdonald@mentor.com>2015-01-26 08:53:51 -0500
commite18830c2b4323487f9afa5205f13579903c7f9d4 (patch)
tree223d4b9f9337d18cbd4055c55d041bef0a36a021
parentddd3ccd63949f9a24040eb39c136ef9730f2662a (diff)
downloadmeta-openembedded-contrib-e18830c2b4323487f9afa5205f13579903c7f9d4.tar.gz
opensaf: add recipe
OpenSAF is an open source implementation of the SAF AIS specification Signed-off-by: Bian Naimeng <biannm@cn.fujitsu.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
-rw-r--r--meta-networking/recipes-daemons/opensaf/opensaf/install-samples-from-srcdir.patch11
-rw-r--r--meta-networking/recipes-daemons/opensaf/opensaf_4.5.0.bb40
2 files changed, 51 insertions, 0 deletions
diff --git a/meta-networking/recipes-daemons/opensaf/opensaf/install-samples-from-srcdir.patch b/meta-networking/recipes-daemons/opensaf/opensaf/install-samples-from-srcdir.patch
new file mode 100644
index 0000000000..016b64f2e9
--- /dev/null
+++ b/meta-networking/recipes-daemons/opensaf/opensaf/install-samples-from-srcdir.patch
@@ -0,0 +1,11 @@
+--- opensaf-4.5.0.orig/Makefile.am 2014-12-31 14:45:54.088797989 +0800
++++ opensaf-4.5.0/Makefile.am 2014-12-31 14:45:08.328796688 +0800
+@@ -219,7 +219,7 @@ install-data-local:
+ $(mkinstalldirs) $(DESTDIR)$(pkgpiddir)
+ $(mkinstalldirs) $(DESTDIR)$(lockdir)
+ $(mkinstalldirs) $(DESTDIR)$(pkglocalstatedir)
+- cp -R samples/ $(DESTDIR)$(pkgdatadir)
++ cp -R $(srcdir)/samples/ $(DESTDIR)$(pkgdatadir)
+
+ install-data-hook:
+ @for i in $$(grep -lr -e 'xxLIBDIRxx' -e 'xxLOGDIRxx' -e 'xxCLCCLIDIRxx' $(DESTDIR)$(pkgimmxml_svcdir)/*.xml) ; do \
diff --git a/meta-networking/recipes-daemons/opensaf/opensaf_4.5.0.bb b/meta-networking/recipes-daemons/opensaf/opensaf_4.5.0.bb
new file mode 100644
index 0000000000..a58de5ce43
--- /dev/null
+++ b/meta-networking/recipes-daemons/opensaf/opensaf_4.5.0.bb
@@ -0,0 +1,40 @@
+SUMMARY = "OpenSAF is an open source implementation of the SAF AIS specification"
+DESCRIPTION = "OpenSAF is an open source project established to develop a base platform \
+middleware consistent with Service Availability Forum (SA Forum) \
+specifications, under the LGPLv2.1 license. The OpenSAF Foundation was \
+established by leading Communications and Enterprise Computing Companies to \
+facilitate the OpenSAF Project and to accelerate the adoption of the OpenSAF \
+code base in commercial products. \
+The OpenSAF project was launched in mid 2007 and has been under development by \
+an informal group of supporters of the OpenSAF initiative. The OpenSAF \
+Foundation was founded on January 22nd 2008 with Emerson Network Power, \
+Ericsson, Nokia Siemens Networks, HP and Sun Microsystems as founding members."
+HOMEPAGE = "http://www.opensaf.org"
+
+inherit autotools useradd systemd pkgconfig
+
+SRC_URI = "http://jaist.dl.sourceforge.net/project/opensaf/releases/${BPN}-${PV}.tar.gz \
+ file://install-samples-from-srcdir.patch"
+
+SRC_URI[md5sum] = "534c0a99438a62c4c8dda56cfa67300c"
+SRC_URI[sha256sum] = "2f5ba57fe67e94099c0df82d0a0dd207b5c583c93030035ba354c97b5471b590"
+
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=a916467b91076e631dd8edb7424769c7"
+
+DEPENDS = "libxml2 python"
+
+USERADD_PACKAGES = "${PN}"
+GROUPADD_PARAM_${PN} = "-f -r opensaf"
+USERADD_PARAM_${PN} = "-r -g opensaf -d ${datadir}/opensaf/ -s ${sbindir}/nologin -c \"OpenSAF\" opensaf"
+
+SYSTEMD_SERVICE_${PN} += "opensafd.service"
+SYSTEMD_AUTO_ENABLE = "disable"
+
+FILES_${PN} += "/run"
+
+INSANE_SKIP_${PN} = "dev-so"
+
+do_install_append() {
+ rm -rf "${D}${localstatedir}/run"
+}