aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLi xin <lixin.fnst@cn.fujitsu.com>2015-01-20 18:10:42 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2015-01-28 09:52:51 +0100
commitc8f98b15d0a06938e36de91ebf8b2471e50d21d8 (patch)
tree9d86e5102d3c053b9f90efc3b3e25d62de197f29
parentb3cff5d52c53aed5a6ae50dc492b9543ab5e8b7f (diff)
downloadmeta-openembedded-contrib-c8f98b15d0a06938e36de91ebf8b2471e50d21d8.tar.gz
system-setup-keyboard: add new recipe
system-setup-keyboard is a daemon to monitor the keyboard layout configured in /etc/sysconfig/keyboard and transfer this into the matching xorg.conf.d snippet. Signed-off-by: Li Xin <lixin.fnst@cn.fujitsu.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-support/system-setup-keyboard/system-setup-keyboard_0.8.8.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/system-setup-keyboard/system-setup-keyboard_0.8.8.bb b/meta-oe/recipes-support/system-setup-keyboard/system-setup-keyboard_0.8.8.bb
new file mode 100644
index 0000000000..d2199c2cf7
--- /dev/null
+++ b/meta-oe/recipes-support/system-setup-keyboard/system-setup-keyboard_0.8.8.bb
@@ -0,0 +1,29 @@
+SUMMARY = "xorg.conf keyboard layout callout"
+DESCRIPTION = "system-setup-keyboard is a daemon to monitor the keyboard layout configured in \
+/etc/sysconfig/keyboard and transfer this into the matching xorg.conf.d snippet."
+
+HOMEPAGE = "https://git.fedorahosted.org/git/system-setup-keyboard.git"
+SECTION = "Applications/System"
+
+SRC_URI = "https://git.fedorahosted.org/cgit/${PN}.git/snapshot/${BP}.tar.gz"
+SRC_URI[md5sum] = "399003968ccc739cddd9cc370af377a0"
+SRC_URI[sha256sum] = "1ef6ef79c3588e85d7f42e99eb80a2e459f966284cf029c2d6fc1b645abcb860"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=bf57969a59612c5aca007b340c49d3a2"
+
+inherit pythonnative
+
+DEPENDS = "glib-2.0 system-config-keyboard-native"
+
+do_compile_prepend() {
+ ${PYTHON} -v get_layouts.py > keyboards.h
+}
+
+do_install() {
+ oe_runmake install DESTDIR=${D}
+ install -d ${D}/etc/X11/xorg.conf.d
+ touch ${D}/etc/X11/xorg.conf.d/00-system-setup-keyboard.conf
+}
+
+FILES_${PN} += "${systemd_unitdir}/system/${PN}.service"