aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorleimaohui <leimaohui@cn.fujitsu.com>2015-01-09 14:07:31 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2015-01-12 15:34:45 +0100
commitafeac90022fb62fddf179fa21cd4132da18153fb (patch)
tree2ae8992f6a1ffe55e7f180be46e983e15cf92b9b
parentc702fc4dfab0c09449bd47a04deecca5946d981f (diff)
downloadmeta-openembedded-contrib-afeac90022fb62fddf179fa21cd4132da18153fb.tar.gz
libqb: add new recipe
An IPC library for high performance servers. Signed-off-by: Lei Maohui <leimaohui@cn.fujitsu.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-extended/libqb/libqb_0.17.1.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/libqb/libqb_0.17.1.bb b/meta-oe/recipes-extended/libqb/libqb_0.17.1.bb
new file mode 100644
index 0000000000..77307fe002
--- /dev/null
+++ b/meta-oe/recipes-extended/libqb/libqb_0.17.1.bb
@@ -0,0 +1,26 @@
+SUMMARY = "An IPC library for high performance servers"
+DESCRIPTION = "libqb is a library with the primary purpose of providing high performance client server reusable features. \
+It provides high performance logging, tracing, ipc, and poll."
+
+HOMEPAGE = "https://github.com/clusterlabs/libqb/wiki"
+
+SECTION = "libs"
+
+inherit autotools pkgconfig
+
+SRC_URI = "https://fedorahosted.org/releases/q/u/quarterback/${BP}.tar.xz \
+ "
+
+SRC_URI[md5sum] = "5770b343baa4528f6fec90120ec55048"
+SRC_URI[sha256sum] = "7a2115f83bfe20eaa5f2e4ed235e8f2994235d3b87e3e5ca41ba47b320f12e29"
+
+LICENSE = "LGPL-2.1"
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=321bf41f280cf805086dd5a720b37785"
+
+do_configure_prepend() {
+ ( cd ${S}
+ ${S}/autogen.sh )
+}
+
+