aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2014-12-30 00:40:17 -0800
committerJoe MacDonald <joe_macdonald@mentor.com>2015-01-05 11:25:51 -0500
commitce11242ddd43286ec2f2f3c27d39362d966b543d (patch)
tree29256d424d830bef74bd01d52e56438b221d3143
parent56183ff4e07f91ce83ae3023ab747a141320c1f4 (diff)
downloadmeta-openembedded-contrib-ce11242ddd43286ec2f2f3c27d39362d966b543d.tar.gz
esmtp: remove sendmail from sysroot
The sysroot/${libdir}/sendmail conflicts with lsb's, and it's a symlink to ${bindir}/esmtp which is meaningless for sysroot, so remove it. Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-networking/recipes-support/esmtp/esmtp_1.2.bb8
1 files changed, 8 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/esmtp/esmtp_1.2.bb b/meta-networking/recipes-support/esmtp/esmtp_1.2.bb
index f7a044296d..69bdaf9943 100644
--- a/meta-networking/recipes-support/esmtp/esmtp_1.2.bb
+++ b/meta-networking/recipes-support/esmtp/esmtp_1.2.bb
@@ -30,3 +30,11 @@ SRC_URI[md5sum] = "79a9c1f9023d53f35bb82bf446150a72"
SRC_URI[sha256sum] = "a0d26931bf731f97514da266d079d8bc7d73c65b3499ed080576ab606b21c0ce"
FILES_${PN} += "${libdir}/"
+
+# The sysroot/${libdir}/sendmail conflicts with lsb's, and it's a
+# symlink to ${bindir}/esmtp which is meaningless for sysroot, so
+# remove it.
+SYSROOT_PREPROCESS_FUNCS += "remove_sysroot_sendmail"
+remove_sysroot_sendmail() {
+ rm -r "${SYSROOT_DESTDIR}${libdir}/sendmail"
+}