aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-09-20 15:32:21 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-09-22 22:50:47 +0000
commit92e58a8cf4e40f9df19ff187b34dd58b29dba500 (patch)
tree74a8ceed097f8b4a842b267b8f66db550a75dc9d
parent0707846a98855fe05acac761b2ba20547173fef9 (diff)
downloadmeta-openembedded-contrib-92e58a8cf4e40f9df19ff187b34dd58b29dba500.tar.gz
luajit: Fix mips build with clang
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-devtools/luajit/luajit/clang.patch19
-rw-r--r--meta-oe/recipes-devtools/luajit/luajit_2.0.5.bb1
2 files changed, 20 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/luajit/luajit/clang.patch b/meta-oe/recipes-devtools/luajit/luajit/clang.patch
new file mode 100644
index 0000000000..c39ef6fd4a
--- /dev/null
+++ b/meta-oe/recipes-devtools/luajit/luajit/clang.patch
@@ -0,0 +1,19 @@
+clang pretends to be gcc 4.2.0 which is a big lie when it comes
+to features, its same as latest gcc
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+Upstream-Status: Pending
+
+Index: LuaJIT-2.0.5/src/lj_arch.h
+===================================================================
+--- LuaJIT-2.0.5.orig/src/lj_arch.h
++++ LuaJIT-2.0.5/src/lj_arch.h
+@@ -313,7 +313,7 @@
+ #error "Need at least GCC 4.2 or newer"
+ #endif
+ #elif !LJ_TARGET_PS3
+-#if (__GNUC__ < 4) || ((__GNUC__ == 4) && __GNUC_MINOR__ < 3)
++#if (__GNUC__ < 4) || ((__GNUC__ == 4) && __GNUC_MINOR__ < 3) && !defined(__clang__)
+ #error "Need at least GCC 4.3 or newer"
+ #endif
+ #endif
diff --git a/meta-oe/recipes-devtools/luajit/luajit_2.0.5.bb b/meta-oe/recipes-devtools/luajit/luajit_2.0.5.bb
index d7477ed984..73c38111ef 100644
--- a/meta-oe/recipes-devtools/luajit/luajit_2.0.5.bb
+++ b/meta-oe/recipes-devtools/luajit/luajit_2.0.5.bb
@@ -5,6 +5,7 @@ HOMEPAGE = "http://luajit.org"
SRC_URI = "http://luajit.org/download/LuaJIT-${PV}.tar.gz \
file://0001-Do-not-strip-automatically-this-leaves-the-stripping.patch \
+ file://clang.patch \
"
SRC_URI[md5sum] = "48353202cbcacab84ee41a5a70ea0a2c"
SRC_URI[sha256sum] = "874b1f8297c697821f561f9b73b57ffd419ed8f4278c82e05b48806d30c1e979"