aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-10-07 20:03:34 -0700
committerKhem Raj <raj.khem@gmail.com>2019-10-08 00:54:56 -0700
commit31161b5fee5ae8616f18e135990fd27838c7a6ad (patch)
treeddb59c6f350b0e6624a4a2780c0c63cfb2b7bf72
parentfb0a590c4a21c7303de6f0b048bbc648b0e7f5f5 (diff)
downloadmeta-openembedded-contrib-31161b5fee5ae8616f18e135990fd27838c7a6ad.tar.gz
mongodb: Turn system libpcre support into packageconfig
when libpcre is built with clang and mongodb with gcc then they dont link well, in such cases its better to use in-tree pcre, this paves a way to achieve that if needed Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-dbs/mongodb/mongodb_git.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta-oe/recipes-dbs/mongodb/mongodb_git.bb b/meta-oe/recipes-dbs/mongodb/mongodb_git.bb
index e7e03a4e14..cd8ccdc8ab 100644
--- a/meta-oe/recipes-dbs/mongodb/mongodb_git.bb
+++ b/meta-oe/recipes-dbs/mongodb/mongodb_git.bb
@@ -3,7 +3,7 @@ LICENSE = "SSPL-1 & Apache-2.0 & Zlib"
LIC_FILES_CHKSUM = "file://LICENSE-Community.txt;md5=3a865f27f11f43ecbe542d9ea387dcf1 \
file://APACHE-2.0.txt;md5=3b83ef96387f14655fc854ddc3c6bd57"
-DEPENDS = "openssl libpcre libpcap zlib boost curl python3 \
+DEPENDS = "openssl libpcap zlib boost curl python3 \
python3-setuptools-native \
python3-pyyaml-native python3-cheetah-native \
python3-psutil-native python3-regex-native \
@@ -38,7 +38,7 @@ S = "${WORKDIR}/git"
COMPATIBLE_HOST ?= '(x86_64|powerpc64|aarch64).*-linux'
-PACKAGECONFIG ??= "tcmalloc"
+PACKAGECONFIG ??= "tcmalloc system-pcre"
# gperftools compilation fails for arm below v7 because of missing support of
# dmb operation. So we use system-allocator instead of tcmalloc
PACKAGECONFIG_remove_armv6 = "tcmalloc"
@@ -46,6 +46,7 @@ PACKAGECONFIG_remove_libc-musl = "tcmalloc"
PACKAGECONFIG[tcmalloc] = "--use-system-tcmalloc,--allocator=system,gperftools,"
PACKAGECONFIG[shell] = ",--js-engine=none,,"
+PACKAGECONFIG[system-pcre] = "--use-system-pcre,,libpcre,"
EXTRA_OESCONS = "--prefix=${D}${prefix} \
LIBPATH=${STAGING_LIBDIR} \
@@ -54,7 +55,6 @@ EXTRA_OESCONS = "--prefix=${D}${prefix} \
TARGET_ARCH=${TARGET_ARCH} \
--ssl \
--disable-warnings-as-errors \
- --use-system-pcre \
--use-system-zlib \
--nostrip \
--endian=${@oe.utils.conditional('SITEINFO_ENDIANNESS', 'le', 'little', 'big', d)} \