aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorIgor Santos <igor.santos@aker.com.br>2015-05-08 15:06:07 -0300
committerMartin Jansa <Martin.Jansa@gmail.com>2015-05-13 14:34:24 +0200
commitf351653c8089f033ce5d3b890a1b5a8e15bcb45b (patch)
tree78adbfce7451bbc956f35a081c82fff84a882fa7
parentdce88e4a2c0b28022ef7fa63896aad35cc011cb8 (diff)
downloadmeta-openembedded-contrib-f351653c8089f033ce5d3b890a1b5a8e15bcb45b.tar.gz
ctags: add
Ctags generates an index (or tag) file of language objects found in source files that allows these items to be quickly and easily located by a text editor or other utility. A tag signifies a language object for which an index entry is available (or, alternatively, the index entry created for that object). Signed-off-by: Igor Santos <igor.santos@aker.com.br> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-devtools/ctags/ctags_5.8.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/ctags/ctags_5.8.bb b/meta-oe/recipes-devtools/ctags/ctags_5.8.bb
new file mode 100644
index 0000000000..6fc39125b6
--- /dev/null
+++ b/meta-oe/recipes-devtools/ctags/ctags_5.8.bb
@@ -0,0 +1,25 @@
+# Copyright (C) 2015 Igor Santos <igor.santos@aker.com.br>
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+SUMMARY = "Exuberant Ctags"
+DESCRIPTION = "Exuberant Ctags is a multilanguage reimplementation of the \
+ Unix ctags utility. Ctags generates an index of source code \
+ definitions which is used by numerous editors and utilities \
+ to instantly locate the definitions."
+
+HOMEPAGE = "http://ctags.sourceforge.net/"
+
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
+
+inherit autotools-brokensep
+
+SRC_URI = "http://prdownloads.sourceforge.net/${PN}/${PN}-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "c00f82ecdcc357434731913e5b48630d"
+SRC_URI[sha256sum] = "0e44b45dcabe969e0bbbb11e30c246f81abe5d32012db37395eb57d66e9e99c7"
+
+do_install() {
+ install -Dm 755 ${B}/ctags ${D}${bindir}/ctags
+ install -Dm 644 ${B}/ctags.1 ${D}${mandir}/man1/ctags.1
+}