aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Balister <philip@balister.org>2018-07-24 09:43:00 -0400
committerKhem Raj <raj.khem@gmail.com>2018-08-19 16:09:28 -0700
commitdf411368c0d342ad34094ab8ff022b52caf8fdda (patch)
treea547277bd76dd879a8e28d1e043fc13d651e8aad
parent864eb0024f6f8cf91b3484fb002bf89f94fbb1ea (diff)
downloadmeta-openembedded-contrib-df411368c0d342ad34094ab8ff022b52caf8fdda.tar.gz
lapack: Add recipe.
* Build tested. * Note: needs FORTRAN enabled in local.conf or similar. * Used to build scipy on pi-3. scipy passed many tests. * Based on work from meta-gnss https://github.com/carlesfernandez/meta-gnss-sdr * Hopefully this helps others playing with scipy and things. Signed-off-by: Philip Balister <philip@balister.org> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-devtools/lapack/lapack_3.8.0.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/lapack/lapack_3.8.0.bb b/meta-oe/recipes-devtools/lapack/lapack_3.8.0.bb
new file mode 100644
index 0000000000..ef1abd5675
--- /dev/null
+++ b/meta-oe/recipes-devtools/lapack/lapack_3.8.0.bb
@@ -0,0 +1,24 @@
+SUMMARY = "Linear Algebra PACKage"
+URL = "http://www.netlib.org/lapack"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=930f8aa500a47c7dab0f8efb5a1c9a40"
+
+# Recipe needs FORTRAN support (copied from conf/local.conf.sample.extended)
+# Enabling FORTRAN
+# Note this is not officially supported and is just illustrated here to
+# show an example of how it can be done
+# You'll also need your fortran recipe to depend on libgfortran
+#FORTRAN_forcevariable = ",fortran"
+#RUNTIMETARGET_append_pn-gcc-runtime = " libquadmath"
+
+DEPENDS = "libgfortran"
+
+SRC_URI = "http://www.netlib.org/lapack/lapack-${PV}.tar.gz"
+SRC_URI[md5sum] = "96591affdbf58c450d45c1daa540dbd2"
+SRC_URI[sha256sum] = "deb22cc4a6120bff72621155a9917f485f96ef8319ac074a7afbc68aab88bcf6"
+
+EXTRA_OECMAKE = " -DBUILD_SHARED_LIBS=ON "
+OECMAKE_GENERATOR = "Unix Makefiles"
+
+inherit cmake pkgconfig
+